Last Comment Bug 670870 - HTML table and caption should be linked by label relations
: HTML table and caption should be linked by label relations
Status: RESOLVED FIXED
[qa-]
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: alexander :surkov
:
Mentors:
Depends on: 666212
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 00:54 PDT by alexander :surkov
Modified: 2011-09-22 16:01 PDT (History)
3 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (3.06 KB, patch)
2011-07-12 00:54 PDT, alexander :surkov
mzehe: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description alexander :surkov 2011-07-12 00:54:31 PDT
Created attachment 545330 [details] [diff] [review]
patch

spun off bug 666212 where we started to expose caption as name (against description). That means caption and table should be linked by labelled_by/label_for relations (not description_for/described_by).
Comment 1 Marco Zehe (:MarcoZ) 2011-07-12 02:59:46 PDT
Comment on attachment 545330 [details] [diff] [review]
patch

Ah, thanks for fixing this Alex! :)
Comment 2 alexander :surkov 2011-07-14 01:13:32 PDT
landed http://hg.mozilla.org/mozilla-central/rev/4274ccb37cf6

Marco, could you drive to port the patch into mozilla 7 since this bug and bug 666212 should be distributed together?
Comment 3 Marco Zehe (:MarcoZ) 2011-07-14 06:33:49 PDT
Comment on attachment 545330 [details] [diff] [review]
patch

Requesting approval for Mozilla-aurora since this bug completes a feature implemented for Mozilla7. Zero risk, has tests.
Comment 4 Marco Zehe (:MarcoZ) 2011-07-15 06:50:38 PDT
Landed on Aurora for Firefox 7: http://hg.mozilla.org/releases/mozilla-aurora/rev/4d2a4e9e9730
Comment 5 alexander :surkov 2011-07-15 07:01:25 PDT
(In reply to comment #4)
> Landed on Aurora for Firefox 7:
> http://hg.mozilla.org/releases/mozilla-aurora/rev/4d2a4e9e9730

Thanks, Marco!
Comment 6 Simona B [:simonab ] -PTO- back Sept 5th 2011-08-19 08:12:49 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

Can anyone please help me with a test case or with STR/guidelines in order to get this issue checked on QA side?
Thanks!
Comment 7 alexander :surkov 2011-08-26 02:59:43 PDT
(In reply to Simona B from comment #6)
> Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
> 
> Can anyone please help me with a test case or with STR/guidelines in order
> to get this issue checked on QA side?
> Thanks!

The patch has mochitests so maybe it's not necessary to check it manually. But if you think it's necessary then it makes sense to ask Marco how can it be checked with screen readers or ask him to do that since he's accessibility QA.
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-09-22 16:01:31 PDT
qa- as no QA fix verification needed

Note You need to log in before you can comment on or make changes to this bug.