Last Comment Bug 670874 - Tests all attributes in test_textarea_attributes_reflection.html
: Tests all attributes in test_textarea_attributes_reflection.html
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 01:48 PDT by Mounir Lamouri (:mounir)
Modified: 2011-07-22 14:05 PDT (History)
3 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (13.36 KB, patch)
2011-07-12 01:48 PDT, Mounir Lamouri (:mounir)
Ms2ger: review+
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2011-07-12 01:48:30 PDT
Created attachment 545340 [details] [diff] [review]
Patch v1
Comment 1 :Ms2ger 2011-07-13 08:12:41 PDT
Comment on attachment 545340 [details] [diff] [review]
Patch v1

--- a/content/html/content/test/reflect.js
+++ b/content/html/content/test/reflect.js
+  // TODO: remove this ugly hack when null stringification will work as expected.
+  if (element.tagName == "TEXTAREA" && idlAttr == "wrap") {

I'd prefer an extra parameter, so we can fix the attributes one by one.
Comment 2 Mounir Lamouri (:mounir) 2011-07-19 11:44:59 PDT
(In reply to comment #1)
> Comment on attachment 545340 [details] [diff] [review] [review]
> Patch v1
> 
> --- a/content/html/content/test/reflect.js
> +++ b/content/html/content/test/reflect.js
> +  // TODO: remove this ugly hack when null stringification will work as
> expected.
> +  if (element.tagName == "TEXTAREA" && idlAttr == "wrap") {
> 
> I'd prefer an extra parameter, so we can fix the attributes one by one.

If it happens that we actually fix the attributes one by one, adding a parameter would be useful. For the moment, I don't think we need it.
Comment 3 :Ms2ger 2011-07-19 14:39:02 PDT
OK. When you reland it, I'd slightly prefer testing localName rather than tagName, though.
Comment 4 Marco Bonardo [::mak] 2011-07-20 06:55:50 PDT
this has been backed out by ehsan due to bustage with all the other changesets in the same push
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2011-07-22 14:05:49 PDT
http://hg.mozilla.org/mozilla-central/rev/780471850bcf

Note You need to log in before you can comment on or make changes to this bug.