Last Comment Bug 670962 - Make nsGenericDOMDataNode and nsTextFragment participate to the DOM Memory Reporter
: Make nsGenericDOMDataNode and nsTextFragment participate to the DOM Memory Re...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks: 663271
  Show dependency treegraph
 
Reported: 2011-07-12 09:59 PDT by Mounir Lamouri (:mounir)
Modified: 2011-07-25 05:58 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.70 KB, patch)
2011-07-12 09:59 PDT, Mounir Lamouri (:mounir)
jst: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-07-12 09:59:12 PDT
Created attachment 545397 [details] [diff] [review]
Patch v1
Comment 1 Johnny Stenback (:jst, jst@mozilla.com) 2011-07-12 16:58:58 PDT
Comment on attachment 545397 [details] [diff] [review]
Patch v1

- In nsTextFragment::SizeOf():

+    PRInt64 size = sizeof(*this);
+    size += GetLength() * Is2b() ? sizeof(*m2b) : sizeof(*m1b);

We should only add the size of the text itself if mState.mInHeap is true, if not, it's a text fragment that points to a shared static whitespace string.

r=jst with that.
Comment 2 Marco Bonardo [::mak] 2011-07-20 06:56:33 PDT
this has been backed out by ehsan due to bustage with all the other changesets in the same push
Comment 3 Marco Bonardo [::mak] 2011-07-25 05:58:48 PDT
http://hg.mozilla.org/mozilla-central/rev/0ea1783b5f6e

Note You need to log in before you can comment on or make changes to this bug.