Last Comment Bug 670986 - Create nsLocation.h to declare nsLocation instead of doing that in nsGlobalWindow.h
: Create nsLocation.h to declare nsLocation instead of doing that in nsGlobalWi...
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 10:43 PDT by Mounir Lamouri (:mounir)
Modified: 2011-08-03 02:28 PDT (History)
4 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (5.29 KB, patch)
2011-07-12 10:43 PDT, Mounir Lamouri (:mounir)
no flags Details | Diff | Splinter Review
Patch v1.1 (9.01 KB, patch)
2011-07-13 03:29 PDT, Mounir Lamouri (:mounir)
no flags Details | Diff | Splinter Review
Patch v1.2 (8.98 KB, patch)
2011-07-13 03:33 PDT, Mounir Lamouri (:mounir)
jst: review+
Details | Diff | Splinter Review
Patch v1.3 (9.49 KB, patch)
2011-07-25 15:15 PDT, Mounir Lamouri (:mounir)
no flags Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-07-12 10:43:35 PDT
Created attachment 545415 [details] [diff] [review]
Patch v1
Comment 1 Johnny Stenback (:jst, jst@mozilla.com) 2011-07-12 17:00:25 PDT
Um, did you forget to hg add nsLocation.h? :)
Comment 2 Mounir Lamouri (:mounir) 2011-07-13 03:29:43 PDT
Created attachment 545634 [details] [diff] [review]
Patch v1.1

Oups :)
Comment 3 Mounir Lamouri (:mounir) 2011-07-13 03:33:09 PDT
Created attachment 545637 [details] [diff] [review]
Patch v1.2

Without SizeOf() declaration, it might be even better...
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2011-07-13 11:37:24 PDT
I've wanted to do that for quite a while... Thanks!
Comment 5 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-07-20 06:56:49 PDT
this has been backed out by ehsan due to bustage with all the other changesets in the same push
Comment 6 Mounir Lamouri (:mounir) 2011-07-25 15:15:58 PDT
Created attachment 548304 [details] [diff] [review]
Patch v1.3

Trying to figure out why this is failing to build on Windows...
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-08-03 02:28:33 PDT
http://hg.mozilla.org/mozilla-central/rev/b53395484bdf

Note You need to log in before you can comment on or make changes to this bug.