buildsymbols takes very long on Windows 2008 64-bit (VS2008)

RESOLVED DUPLICATE of bug 669384

Status

()

--
major
RESOLVED DUPLICATE of bug 669384
7 years ago
4 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Trunk
x86_64
Windows Server 2008
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (not a blocker) need patch for getting timestamps in log)

(Reporter)

Description

7 years ago
On bug 669384#c7 I noticed that building symbols on Windows 2008 with VS2008 takes a very long time.

On Windows 2003 VS2005 takes 5 minutes while on the 64-bit machines takes a little more than 45 minutes.

This is important to improve so we can
It'd be interesting to figure out what exactly is taking so long. Maybe we should put some timestamps in the log?
Component: Build Config → Breakpad Integration
Product: Core → Toolkit
QA Contact: build-config → breakpad.integration
(Reporter)

Updated

7 years ago
Whiteboard: (not a blocker) need patch for getting timestamps in log

Comment 2

6 years ago
There's a chance, that using cross compiling (e.g. 64 bit build made with 32 bit toolchain) will not suffer from this problem. It is possible to compile on 64 bit machine with 32 bit cross compiler.
(Reporter)

Comment 3

6 years ago
Hi Lost,
Thanks for your information in all those bugs. Once this project becomes a higher priority it will very helpful.

Unfortunately, Windows 64-bit is not going to be officially supported:
https://groups.google.com/d/msg/mozilla.dev.planning/Giij-AZfUAM/XFtqZGJjnQ8J

Comment 4

5 years ago
Should this bug be closed? According to https://developer.mozilla.org/en-US/docs/Developer_Guide/Build_Instructions/Windows_Prerequisites , VS2008 is no longer supported...
We'll just dupe it over to bug 669384, which has information on the upstream bug filed with Microsoft (it's fixed in an unknown release).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669384
You need to log in before you can comment on or make changes to this bug.