Closed Bug 671052 Opened 11 years ago Closed 11 years ago

Text selection highlight sometimes replaced with blinking cursor when using handles

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 667243

People

(Reporter: aaronmt, Unassigned)

References

Details

Attachments

(1 file)

Attached image Blinking cursor
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110712 Firefox/8.0a1 Fennec/8.0a1
Device: HTC Nexus One
Android: 2.3.4

Once in a while, when I want to text select instead of seeing a highlight in my text selection I will get a blinking cursor that can be moved with the handles. For some reason I can't reproduce this on all pages with text, but I can reproduce this all the time on the article in the URL below [1]

See screenshot with the cursor on the word determining which I wanted to select.

[1] http://hackaday.com/2011/07/12/character-lcd-screen-add-on-for-android-devices/
Forgot to mention, this is triggered when I move a handle after an initial selection.
Summary: Text selection highlight sometimes replaced with blinking cursor → Text selection highlight sometimes replaced with blinking cursor when using handles
This is because we currently use the "caret mode" and fake mouse clicks to do the text highlight. Creating a real API will allow us to stop using the hack.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 667243
You need to log in before you can comment on or make changes to this bug.