Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 671201 - alert dialogs aren't read by JAWS
: alert dialogs aren't read by JAWS
Status: RESOLVED DUPLICATE of bug 661293
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: alexander :surkov
: 675655 (view as bug list)
Depends on: 661293
Blocks: jaws
  Show dependency treegraph
Reported: 2011-07-13 01:03 PDT by alexander :surkov
Modified: 2012-02-20 07:35 PST (History)
7 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description alexander :surkov 2011-07-13 01:03:51 PDT
spun off bug 617918 comment #1, original report:

JAWS does not read text message in new alert dialog in Firefox 4 and 5.
Frank asked to add this issue as additional information to this defect. 

An alert message is issued using, javascript:alert("Test Message"); This can be done just by typing this line into the address field in the browser. 

In Firefox 3.6, JAWS would read the text in the alert dialog. With Firefox 4 and 5, we have found two issues. First, focus is not placed on the dialog box. Actually, watching the events in AccProbe shows that the focus goes to the OK button but then goes back to the browser window.

If focus is placed on the OK button, we find that JAWS can read the OK button but does not read the text message. I tried both Insert + B and Ctrl +Home, Insert + Down Arrow.
Comment 1 Marco Zehe (:MarcoZ) 2011-07-13 02:01:39 PDT
Yes, for some reason we are no longer picking up the labels via aria-describedby in the new tab-based alert dialog. The markup is correct, though.
Comment 2 Marco Zehe (:MarcoZ) 2011-08-02 01:14:20 PDT
*** Bug 675655 has been marked as a duplicate of this bug. ***
Comment 3 alexander :surkov 2012-02-19 21:57:02 PST
depends on bug 661293, actually could be a dupe.
Comment 4 alexander :surkov 2012-02-20 07:35:47 PST
a dupe, when the dialog exposes description_for relation then JAWS works fine

*** This bug has been marked as a duplicate of bug 661293 ***

Note You need to log in before you can comment on or make changes to this bug.