Last Comment Bug 671255 - Pressing space at the start of a GCLI command shows misaligned completion
: Pressing space at the start of a GCLI command shows misaligned completion
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
:
Mentors:
Depends on:
Blocks: GCLI-ENABLE
  Show dependency treegraph
 
Reported: 2011-07-13 06:39 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2011-08-04 07:53 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-07-13 06:39:18 PDT
When the command line is empty (using | for the cursor and _ for space)
> |

Pressing space gives:
> _e|val

Where eval is the completion text.


1. At the very least we should show the completion text aligned with the cursor. This is more obvious when typing starts:
> _a|
(the word l*rt is written as the completion text (* is under the a))

2. I've not looked into why eval should be chosen - there doesn't seem to be any logic behind that choice - probably 'alert' would be better.

3. Should we even be showing any completion text at all? We consciously don't to start off with because it looks confusing, so probably we shouldn't here too.

Note You need to log in before you can comment on or make changes to this bug.