Closed Bug 671276 Opened 11 years ago Closed 3 years ago

crash @ nsBlockFrame::BuildDisplayList

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: nhirata, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-af47c5af-5abd-40cf-b03f-f11792110712 .
============================================================= 
Frame 	Module 	Signature [Expand] 	Source
0 	libc.so 	libc.so@0x11dc0 	
1 	libc.so 	libc.so@0x18f2a 	
2 	libc.so 	libc.so@0x4254b 	
3 	libc.so 	libc.so@0x4254b 	
4 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:76
5 	org.mozilla.firefox_beta-2.apk 	org.mozilla.firefox_beta-2.apk@0x11f2120 	
6 	libxul.so 	nsBuiltinDecoderStateMachine::Run 	nsAutoPtr.h:155
7 		@0xbe918693 	
8 	libxul.so 	nsBlockFrame::BuildDisplayList 	layout/generic/nsBlockFrame.cpp:6221
9 	libxul.so 	nsIFrame::BuildDisplayListForChild 	layout/generic/nsFrame.cpp:1720
10 	libmozalloc.so 	moz_xmalloc 	memory/mozalloc/mozalloc.cpp:101
11 	libxul.so 	mozilla::layers::ShadowLayerForwarder::DestroyedThebesBuffer 	nsTArray-inl.h:78
12 	libxul.so 	mozilla::layers::BasicShadowableThebesLayer::CreateBuffer 	gfx/layers/basic/BasicLayers.cpp:1828
13 	libxul.so 	mozilla::layers::BasicThebesLayerBuffer::CreateBuffer 	gfx/layers/basic/BasicLayers.cpp:676
14 	libxul.so 	mozilla::layers::ThebesLayerBuffer::BeginPaint 	gfx/layers/ThebesLayerBuffer.cpp:368
15 	libxul.so 	mozilla::layers::BasicThebesLayer::PaintThebes 	nsRegion.h:387
16 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	gfx/layers/basic/BasicLayers.cpp:1543
17 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	gfx/layers/basic/BasicLayers.cpp:1556
18 	libxul.so 	mozilla::layers::BasicLayerManager::EndTransactionInternal 	gfx/layers/basic/BasicLayers.cpp:1419
19 	libxul.so 	mozilla::layers::BasicLayerManager::EndTransaction 	gfx/layers/basic/BasicLayers.cpp:1348
20 	libxul.so 	mozilla::layers::BasicShadowLayerManager::EndTransaction 	gfx/layers/basic/BasicLayers.cpp:2917
21 	libxul.so 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:632
22 	libxul.so 	nsDisplayList::PaintRoot 	layout/base/nsDisplayList.cpp:540
23 	libxul.so 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1642
24 	libxul.so 	PresShell::Paint 	layout/base/nsPresShell.cpp:6250
25 	libxul.so 	nsViewManager::RenderViews 	view/src/nsViewManager.cpp:428
26 	libxul.so 	nsViewManager::Refresh 	view/src/nsViewManager.h:239
27 	libxul.so 	nsViewManager::DispatchEvent 	nsCOMPtr.h:492
28 	libxul.so 	HandleEvent 	nsCOMPtr.h:492
29 	libxul.so 	mozilla::widget::PuppetWidget::DispatchEvent 	widget/src/xpwidgets/PuppetWidget.cpp:325
30 	libxul.so 	mozilla::widget::PuppetWidget::DispatchPaintEvent 	widget/src/xpwidgets/PuppetWidget.cpp:534
31 	libxul.so 	mozilla::widget::PuppetWidget::PaintTask::Run 	widget/src/xpwidgets/PuppetWidget.cpp:576
32 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
33 	libxul.so 	NS_ProcessNextEvent_P 	objdir/xpcom/build/nsThreadUtils.cpp:245
34 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
35 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:230
36 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
37 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:511
38 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:191
39 	libxul.so 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp:671
40 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:222
41 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
42 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:511
43 	libxul.so 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp:514
44 	libmozutils.so 	ChildProcessInit 	other-licenses/android/APKOpen.cpp:797
45 	plugin-container 	main 	ipc/app/MozillaRuntimeMainAndroid.cpp:69
46 	libc.so 	libc.so@0xd4e2

https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-07-13%2005%3A00%3A00&signature=libc.so%400x11dc0&version=Fennec%3A6.0
I am also noticing a different signature :
Frame 	Module 	Signature [Expand] 	Source
0 	libc.so 	libc.so@0x11dc0 	
1 	libc.so 	libc.so@0x18f2a 	
2 	libc.so 	libc.so@0x4254b 	
3 	libc.so 	libc.so@0x4254b 	
4 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:76
5 	org.mozilla.firefox_beta-1.apk 	org.mozilla.firefox_beta-1.apk@0x11f2120 	
6 	libxul.so 	nsBuiltinDecoderStateMachine::Run 	nsAutoPtr.h:155
7 		@0xbe9bd6c3 	
8 	libxul.so 	nsIFrame::InvalidateInternal 	layout/generic/nsFrame.cpp:4181
Crash Signature: [@ libc.so@0x11dc0] → [@ libc.so@0x11dc0] [@ nsBlockFrame::BuildDisplayList]
Summary: crash [@ libc.so@0x11dc0 ] → crash [@ libc.so@0x11dc0 ][@ nsBlockFrame::BuildDisplayList]
Crash Signature: [@ libc.so@0x11dc0] [@ nsBlockFrame::BuildDisplayList] → [@ libc.so@0x11dc0] [@ libc.so@0x15d04 ] [@ libc.so@0x15d04] [@ nsBlockFrame::BuildDisplayList]
As libc.so has been added to the Socorro skiplist, I change the crash signature.
Crash Signature: [@ libc.so@0x11dc0] [@ libc.so@0x15d04 ] [@ libc.so@0x15d04] [@ nsBlockFrame::BuildDisplayList] → [@ libc.so@0x11dc0] [@ libc.so@0x15d04] [@ libc.so@0x15d04] [@ mozalloc_abort | org.mozilla.firefox_beta-2.apk@0x11f2120 | nsBuiltinDecoderStateMachine::Run] [@ nsBlockFrame::BuildDisplayList]
OS: Linux → Android
Hardware: All → ARM
Summary: crash [@ libc.so@0x11dc0 ][@ nsBlockFrame::BuildDisplayList] → crash @ nsBlockFrame::BuildDisplayList
Crash Signature: [@ libc.so@0x11dc0] [@ libc.so@0x15d04] [@ libc.so@0x15d04] [@ mozalloc_abort | org.mozilla.firefox_beta-2.apk@0x11f2120 | nsBuiltinDecoderStateMachine::Run] [@ nsBlockFrame::BuildDisplayList] → [@ libc.so@0x11dc0] [@ libc.so@0x15d04] [@ libc.so@0x15d04] [@ mozalloc_abort | org.mozilla.firefox_beta-2.apk@0x11f2120] [@ nsBlockFrame::BuildDisplayList]
Duplicate of this bug: 671281
Crash Signature: [@ libc.so@0x11dc0] [@ libc.so@0x15d04] [@ libc.so@0x15d04] [@ mozalloc_abort | org.mozilla.firefox_beta-2.apk@0x11f2120] [@ nsBlockFrame::BuildDisplayList] → [@ libc.so@0x11dc0] [@ libc.so@0x15d04] [@ libc.so@0x15d04] [@ mozalloc_abort | org.mozilla.firefox_beta-2.apk@0x11f2120] [@ nsBlockFrame::BuildDisplayList]
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.