Last Comment Bug 671341 - GCC 4.6 build warning: nsSMILParserUtils.cpp:317:20: warning: variable ‘start’ set but not used [-Wunused-but-set-variable]
: GCC 4.6 build warning: nsSMILParserUtils.cpp:317:20: warning: variable ‘start...
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Daniel Holbert [:dholbert]
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: buildwarning 474743
  Show dependency treegraph
 
Reported: 2011-07-13 10:47 PDT by Daniel Holbert [:dholbert]
Modified: 2011-07-15 07:04 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (967 bytes, patch)
2011-07-13 10:50 PDT, Daniel Holbert [:dholbert]
bbirtles: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-07-13 10:47:27 PDT
Filing bug on this GCC 4.6 build warning:
{
nsSMILParserUtils.cpp:317:20: warning: variable ‘start’ set but not used [-Wunused-but-set-variab
}

Looks like this has been the case since that chunk of code was added, in Bug 474743:
http://hg.mozilla.org/mozilla-central/diff/192adf25beb3/content/smil/nsSMILParserUtils.cpp#l1.194
but we didn't have a compiler that warned us about it until recently. :)
Comment 1 Daniel Holbert [:dholbert] 2011-07-13 10:50:26 PDT
Created attachment 545704 [details] [diff] [review]
fix
Comment 2 Robert Longson 2011-07-14 04:38:53 PDT
You could combine declaration and assignment here.
Comment 3 Daniel Holbert [:dholbert] 2011-07-14 13:32:25 PDT
Thanks, good point.  I made that tweak before landing.
  http://hg.mozilla.org/integration/mozilla-inbound/rev/61f0230a4a28

Note You need to log in before you can comment on or make changes to this bug.