Closed Bug 67142 Opened 21 years ago Closed 20 years ago

Ctrl+Shift+C keyboard shortcut for "copy as plain text"

Categories

(Core :: DOM: UI Events & Focus Handling, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: jruderman, Assigned: mjudge)

Details

(Keywords: helpwanted)

I'd like a way to copy text straight from a webpage (or from editor) into a 
word processor without carrying over formatting.  Currently I open a notepad 
window, paste into the notepad window, copy from the notepad window, paste into 
the other app, and end up with a blank notepad window to close later.  This 
gets tedious rather quickly.

(Note: some of the time I do the notepad thing, I'm copying directly to a 
program that accepts only plain text anyway, but the app I'm pasting into also 
happens to have a command-line interface and I'm paranoid about bug 57770.)

How about adding a command to the Edit menu called "copy text" with the shortcut
Ctrl+Shift+C that copies only the plain-text version of the selected text to 
the clipboard?  "Cut text" and "paste text" might also be useful, but having 
both "copy text" and "paste text" on the menu might make it unclear that using 
just one of those new shortcuts is sufficient to force a plain-text copy.

Gregory <gregoryNOSPAMy@mac.com> brought this up in n.p.m.wishlist.
See also bug 64647, where PLairo suggested adding a "paste without formatting" 
option.  I like that wording better than my "paste text" (although it is 
slightly long).
->xpapps
Component: XP Toolkit/Widgets → XP Apps: GUI Features
really
Assignee: trudelle → ben
QA Contact: jrgm → sairuh
Component: XP Apps: GUI Features → Keyboard Navigation
Should this really be keyboard navigation?  I'm also proposing adding an item 
to the edit menu, and possibly to the context menus for selections and 
textboxes.
if it's really an selection or editor issue, it should then go into either the
Selection or Editor component.
-> selection
Assignee: ben → mjudge
Component: Keyboard Navigation → Selection
QA Contact: sairuh → blakeross
Keywords: helpwanted
OS: Windows 98 → All
Hardware: PC → All
Target Milestone: --- → Future
This actually goes well with another bug in Composer (Paste As > xxx [dropdown 
list]).  Strictly speaking, I don't think this bug is a duplicate of #64647 since 
that complaint is focused on a specific problem in mail compose (not wanting a 
specific format (<pre>) on paste).  This bug seems to be a general issue of not 
putting any formatting on the clipboard.
In Microsoft Word:
    Edit->Paste Special->Unformatted text
already does what you want.

I don't see the use for this feature. In general, Mozilla provides the clipboard
comments as both HTML and unformatted text at the same time. Adding a seperate
"Copy as text" feature seems useless.
Marking wontfix based on Brian's comment that "paste without formatting" is 
available in most apps that can take both text and formatted text, making "copy 
without formatting" redundant.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
Component: Selection → Keyboard: Navigation
Summary: [rfe] ctrl+shift+c to "copy text" (force plain-text copy) → Ctrl+Shift+C keyboard shortcut for "copy as plain text"
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.