Closed Bug 671439 Opened 9 years ago Closed 9 years ago

[Regression] Notifications does not appear on the corresponding tab

Categories

(Firefox for Android Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(firefox8 affected)

VERIFIED FIXED
Firefox 8
Tracking Status
firefox8 --- affected

People

(Reporter: nhirata, Assigned: wesj)

Details

(Whiteboard: [inbound])

Attachments

(2 files)

Attached image screenshot
Mozilla/5.0 (Android; Linux armv71; rv8.0a1) Gecko/20110712 Firefox/8.0a1 Fennec/8.0a1
Device: HTC Flyer
OS: Android 2.3

1. go to about:home
2. open a new tab and go to http://vingtetun.org/todo
3. go back to the first tab (about:home)

Expected: no offline notification appears
Actual: offline notification will appear

Regression bug 639985
Note:
1. also occurs on current beta release
Not a toaster
Summary: [Regression] Toaster notifications does not appear on the corresponding tab → [Regression] Notifications does not appear on the corresponding tab
Attached patch PatchSplinter Review
Fixes this prompt.

There are two others in /mobile that are going to take more work to fix. One involves the addon blocklist prompt:

mxr.mozilla.org/mozilla-central/source/mobile/components/BlocklistPrompt.js#58

(we don't have a window here yet). The other involves addon installs:

http://mxr.mozilla.org/mozilla-central/source/mobile/chrome/content/browser.js#2406

In that case, desktop finds the window of the request, and then backs that out to find the browser. We don't have the window, so will need to look into alternatives.

There's also an instance in our PopupBlocker code, but it looks like we just skip the notification if the request isn't coming from the selected browser.
Assignee: nobody → wjohnston
Attachment #545928 - Flags: review?(mark.finkle)
Attachment #545928 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mozilla-central/rev/99ba817fef41
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 8
This issue is not reproducible anymore on the latest Aurora build, if steps from comment #0 are performed.

Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110901
Firefox/8.0a1 Fennec/8.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.