The default bug view has changed. See this FAQ.

Misc build-system cleanups

RESOLVED FIXED in mozilla9

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Matheus Kerschbaum, Assigned: Matheus Kerschbaum)

Tracking

Trunk
mozilla9
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-bs)

Attachments

(9 attachments, 8 obsolete attachments)

701 bytes, patch
khuey
: review+
Details | Diff | Splinter Review
759 bytes, patch
khuey
: review+
Details | Diff | Splinter Review
1.10 KB, patch
khuey
: review+
Details | Diff | Splinter Review
1.63 KB, patch
khuey
: review+
Details | Diff | Splinter Review
49.62 KB, patch
khuey
: review+
Details | Diff | Splinter Review
919 bytes, patch
khuey
: review+
Details | Diff | Splinter Review
1.75 KB, patch
khuey
: review+
Details | Diff | Splinter Review
6.79 KB, patch
khuey
: review+
Details | Diff | Splinter Review
36.54 KB, patch
emorley
: checkin+
Details | Diff | Splinter Review
(Assignee)

Description

6 years ago
I keep hitting these when patching the build-system so I figured it was time to get rid of them!
(Assignee)

Comment 1

6 years ago
Created attachment 545798 [details] [diff] [review]
part 1: Remove whitespace from configure
Attachment #545798 - Flags: review?(khuey)
(Assignee)

Comment 2

6 years ago
Created attachment 545799 [details] [diff] [review]
part 2: Remove tabs from configure
Attachment #545799 - Flags: review?(khuey)
(Assignee)

Comment 3

6 years ago
Created attachment 545800 [details] [diff] [review]
part 3: Remove whitespace from autoconf
Attachment #545800 - Flags: review?(khuey)
(Assignee)

Comment 4

6 years ago
Created attachment 545801 [details] [diff] [review]
part 4: Remove tabs from autoconf
Attachment #545801 - Flags: review?(khuey)
(Assignee)

Comment 5

6 years ago
Created attachment 545802 [details] [diff] [review]
part 5: Remove whitespace from config.mk
Attachment #545802 - Flags: review?(khuey)
(Assignee)

Comment 6

6 years ago
Created attachment 545803 [details] [diff] [review]
part 6: Remove tabs from config.mk
Attachment #545803 - Flags: review?(khuey)
(Assignee)

Comment 7

6 years ago
Created attachment 545804 [details] [diff] [review]
part 7: Remove whitespace from rules.mk
Attachment #545804 - Flags: review?(khuey)
(Assignee)

Comment 8

6 years ago
Created attachment 545805 [details] [diff] [review]
part 8: Remove tabs from rules.mk
Attachment #545805 - Flags: review?(khuey)
(Assignee)

Comment 9

6 years ago
Rubber-stamp please, no functionality changes in these patches.
Flags: in-testsuite-
(Assignee)

Updated

6 years ago
Attachment #545798 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Attachment #545799 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Attachment #545800 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Attachment #545801 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Attachment #545802 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Attachment #545803 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Attachment #545804 - Flags: review?(khuey)
(Assignee)

Updated

6 years ago
Attachment #545805 - Flags: review?(khuey)
(Assignee)

Comment 10

6 years ago
And of course, none of this actually builds because configure hates me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can't remember off-hand if check-sync-dirs.py considers whitespace in the file comparison - but (presuming it does) for builds to complete, the same changes will also need to be made to the js/src/config/ and js/src/build/ versions of files that don't appear in the exceptions list, if that helps at all?

http://mxr.mozilla.org/mozilla-central/source/js/src/Makefile.in#626
http://mxr.mozilla.org/mozilla-central/source/js/src/config/check-sync-dirs.py
http://mxr.mozilla.org/mozilla-central/source/js/src/config/check-sync-exceptions
Assignee: nobody → matjk7
Status: NEW → ASSIGNED
(Assignee)

Comment 12

6 years ago
check-sync-dirs.py doesn't prevent builds from compiling, it just turns the tree orange if you forget to change the js/src/ build system counterparts (like I did here).

The problem here is the second patch, which makes configures angry for some reason. All the other parts compile fine IIRC, but I don't know if this small cleanup is worth messing up hg log/blame.
(Assignee)

Comment 13

6 years ago
Created attachment 555309 [details] [diff] [review]
part 1: remove AC_SUBST(MINIMO) from configure

I decided to drop the mass tabs -> spaces change since it breaks configure and rules.mk and doing it manually would be painful. I also ended up removing some unrelated (to the whitespace cleanup) cruft in several places.
Attachment #545798 - Attachment is obsolete: true
Attachment #545799 - Attachment is obsolete: true
Attachment #545800 - Attachment is obsolete: true
Attachment #545801 - Attachment is obsolete: true
Attachment #545802 - Attachment is obsolete: true
Attachment #545803 - Attachment is obsolete: true
Attachment #545804 - Attachment is obsolete: true
Attachment #545805 - Attachment is obsolete: true
Attachment #555309 - Flags: review?(khuey)
(Assignee)

Comment 14

6 years ago
Created attachment 555310 [details] [diff] [review]
part 2: Remove reference to dead MAKEFILES_sun_java variable in toolkit-makefiles.sh
Attachment #555310 - Flags: review?(khuey)
(Assignee)

Comment 15

6 years ago
Created attachment 555311 [details] [diff] [review]
part 3: Remove some javaxpcom left-overs
Attachment #555311 - Flags: review?(khuey)
(Assignee)

Comment 16

6 years ago
Created attachment 555312 [details] [diff] [review]
part 4: Remove some gtkmozembed left-overs
Attachment #555312 - Flags: review?(khuey)
(Assignee)

Comment 17

6 years ago
Created attachment 555313 [details] [diff] [review]
part 5: remove whitespace from configure
Attachment #555313 - Flags: review?(khuey)
(Assignee)

Comment 18

6 years ago
Created attachment 555314 [details] [diff] [review]
part 6: remove whitespace from autoconf
Attachment #555314 - Flags: review?(khuey)
(Assignee)

Comment 19

6 years ago
Created attachment 555315 [details] [diff] [review]
part 7: remove whitespace from config.mk
Attachment #555315 - Flags: review?(khuey)
(Assignee)

Comment 20

6 years ago
Created attachment 555316 [details] [diff] [review]
part 8: remove whitespace from rules.mk
Attachment #555316 - Flags: review?(khuey)
Attachment #555309 - Flags: review?(khuey) → review+
Attachment #555310 - Flags: review?(khuey) → review+
Attachment #555311 - Flags: review?(khuey) → review+
Attachment #555312 - Flags: review?(khuey) → review+
Comment on attachment 555313 [details] [diff] [review]
part 5: remove whitespace from configure

Just skimmed this one, but it looks fine.
Attachment #555313 - Flags: review?(khuey) → review+
Attachment #555315 - Flags: review?(khuey) → review+
Attachment #555316 - Flags: review?(khuey) → review+
Comment on attachment 555314 [details] [diff] [review]
part 6: remove whitespace from autoconf

We can probably kill this NS_USE_NATIVE stuff ...
Attachment #555314 - Flags: review?(khuey) → review+
(Assignee)

Updated

6 years ago
Depends on: 680625
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
http://hg.mozilla.org/projects/build-system/rev/03076dd9a84d
http://hg.mozilla.org/projects/build-system/rev/50492b07b13f
http://hg.mozilla.org/projects/build-system/rev/2932e726f86d
http://hg.mozilla.org/projects/build-system/rev/4cf43c7e1fae
http://hg.mozilla.org/projects/build-system/rev/5e9ae571d6b3
http://hg.mozilla.org/projects/build-system/rev/8f246ed75d3d
http://hg.mozilla.org/projects/build-system/rev/ca65995f24ec
http://hg.mozilla.org/projects/build-system/rev/f14ab53ee6d0
Keywords: checkin-needed
Whiteboard: fixed-in-bs
Target Milestone: --- → mozilla9
(Assignee)

Comment 24

6 years ago
Created attachment 555897 [details] [diff] [review]
bustage fix

Stupid me forgot to change the js/src bits again.
Attachment #555897 - Flags: checkin?
Comment on attachment 555897 [details] [diff] [review]
bustage fix

http://hg.mozilla.org/projects/build-system/rev/718f1de3f105
Attachment #555897 - Flags: checkin? → checkin+
http://hg.mozilla.org/mozilla-central/rev/03076dd9a84d
http://hg.mozilla.org/mozilla-central/rev/50492b07b13f
http://hg.mozilla.org/mozilla-central/rev/2932e726f86d
http://hg.mozilla.org/mozilla-central/rev/4cf43c7e1fae
http://hg.mozilla.org/mozilla-central/rev/5e9ae571d6b3
http://hg.mozilla.org/mozilla-central/rev/8f246ed75d3d
http://hg.mozilla.org/mozilla-central/rev/ca65995f24ec
http://hg.mozilla.org/mozilla-central/rev/f14ab53ee6d0
http://hg.mozilla.org/mozilla-central/rev/718f1de3f105
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.