Last Comment Bug 671475 - IonMonkey does not build for arm
: IonMonkey does not build for arm
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: ARM Linux
: -- normal (vote)
: ---
Assigned To: Marty Rosenberg [:mjrosenb]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-13 20:15 PDT by Marty Rosenberg [:mjrosenb]
Modified: 2011-07-14 17:47 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
turns off ion on arm, also creates a top level flag to turn off pic-typed-arrays (2.99 KB, patch)
2011-07-13 20:15 PDT, Marty Rosenberg [:mjrosenb]
adrake: review+
Details | Diff | Splinter Review

Description Marty Rosenberg [:mjrosenb] 2011-07-13 20:15:42 PDT
Created attachment 545818 [details] [diff] [review]
turns off ion on arm, also creates a top level flag to turn off pic-typed-arrays

The new ion code expects arch specific code in js/src/ion/$ARCH, but so far that code has only been implemented for x86 and x64, leading to the ion branch not building on arm.
Comment 1 Andrew Drake [:adrake] 2011-07-13 23:35:39 PDT
Comment on attachment 545818 [details] [diff] [review]
turns off ion on arm, also creates a top level flag to turn off pic-typed-arrays

Review of attachment 545818 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!

::: js/src/jsapi.cpp
@@ +787,4 @@
>      if (!mem)
>          return NULL;
>  
> +#if defined(JS_METHODJIT) && defined(JS_ION)

In jsinterp.cpp the guard is just "#ifdef JS_ION", so this probably should be the same. Checking METHODJIT too doesn't make too much sense to me: if Ion does end up depending on JM that should probably be handled somewhere more global (i.e. configure.in).
Comment 2 David Anderson [:dvander] 2011-07-14 15:08:49 PDT
Put this patch in my queue since we're about to touch more engine stuff. It needs an AC_SUBST(ENABLE_ION) somewhere.
Comment 3 David Anderson [:dvander] 2011-07-14 15:21:49 PDT
Argh, no, there's more... config/autoconf.mk needs:
    ENABLE_ION = @ENABLE_ION@

(I'm getting bad memories of dealing with this for ENABLE_METHODJIT)

Note You need to log in before you can comment on or make changes to this bug.