Last Comment Bug 671564 - Initialize NS_XPCOM_LIBRARY_FILE from NS_GRE_DIR
: Initialize NS_XPCOM_LIBRARY_FILE from NS_GRE_DIR
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Mike Hommey [:glandium]
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks: 671562
  Show dependency treegraph
 
Reported: 2011-07-14 08:42 PDT by Mike Hommey [:glandium]
Modified: 2011-07-21 08:17 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Initialize NS_XPCOM_LIBRARY_FILE from NS_GRE_DIR (2.16 KB, patch)
2011-07-14 08:43 PDT, Mike Hommey [:glandium]
benjamin: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-07-14 08:42:43 PDT
In NS_InitXPCOM2, NS_XPCOM_LIBRARY_FILE is initialized either from the directory given as an argument to the function, if one, or from the directory service with the NS_XPCOM_CURRENT_PROCESS_DIR key otherwise.

In both cases, it ends up being actually wrong, because it initializes with the application directory, not the GRE directory, which makes NS_XPCOM_LIBRARY_FILE return something wrong on xulrunner.
Comment 1 Mike Hommey [:glandium] 2011-07-14 08:43:34 PDT
Created attachment 545926 [details] [diff] [review]
Initialize NS_XPCOM_LIBRARY_FILE from NS_GRE_DIR

Note You need to log in before you can comment on or make changes to this bug.