Last Comment Bug 671798 - Prefs from $gre/defaults/pref are not used in some cases
: Prefs from $gre/defaults/pref are not used in some cases
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Preferences: Backend (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Mike Hommey [:glandium]
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks: 620931
  Show dependency treegraph
 
Reported: 2011-07-14 23:57 PDT by Mike Hommey [:glandium]
Modified: 2011-07-28 08:24 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Always load $gre/defaults/pref prefs (3.76 KB, patch)
2011-07-21 02:18 PDT, Mike Hommey [:glandium]
benjamin: review+
Details | Diff | Splinter Review
Same patch, as diff -w (2.67 KB, patch)
2011-07-21 02:19 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-07-14 23:57:16 PDT
After bug 620931, $gre/defaults/pref/*.js files are supposed to only be loaded when the application directory and the GRE directory are the same. That was the intent, but the code actually doesn't do that because of the semantics change that happened late in bug 620931. What the code currently does is that it will load $gre/defaults/pref/*.js unless there's an the application directory and the GRE directory are different and the application uses an omni.jar.

This means it works in all cases for plain Firefox but doesn't with xulrunner when the app is omnijar'ed. But xulrunner has its own prefs in $gre/defaults/pref/*.js, most notably when xulrunner itself is not omnijar'ed (like, when running it from the dist/bin directory).

This means we actually have a need to unconditionally load these prefs instead of skipping in some cases.
Comment 1 Mike Hommey [:glandium] 2011-07-21 02:18:08 PDT
Created attachment 547346 [details] [diff] [review]
Always load $gre/defaults/pref prefs
Comment 2 Mike Hommey [:glandium] 2011-07-21 02:19:05 PDT
Created attachment 547347 [details] [diff] [review]
Same patch, as diff -w

Note You need to log in before you can comment on or make changes to this bug.