Last Comment Bug 671837 - GCLI should not allow boolean parameters to be positional
: GCLI should not allow boolean parameters to be positional
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
:
: Brian Grinstead [:bgrins]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-15 06:38 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-08-27 05:25 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-07-15 06:38:22 PDT
If we allow positional boolean parameters, then this is not only allowed, but what is generated by the dialog for a command with a single boolean param:

> foo true

Clicking on the checkbox again gives:

> foo false

Which is the same as 'foo' since all boolean params default to false. This is confusing, particularly given the following 2 synonym for 'foo true'

> foo --name
> foo -n

It seems sensible to just disallow positional boolean params, forcing use of 'foo --name' or 'foo -n'.
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-08-18 09:52:49 PDT
This won't show up if we don't ship commands that violate this rule. Move to GCLI-FUTURE
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-18 09:58:22 PST
Moving GCLI bugs to Developer Tools: Console. Filter on 'baked beans are off'.
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-13 09:27:24 PST
Triage. Filter on PEGASUS.
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-13 09:32:14 PST
Triage. Filter on PEGASUS.
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-04-29 11:23:13 PDT
GCLI Triage.
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-27 05:25:17 PDT
Triage.

Note You need to log in before you can comment on or make changes to this bug.