Note: There are a few cases of duplicates in user autocompletion which are being worked on.

After editing location bar, select-all + copy is missing the initial "http://"

RESOLVED DUPLICATE of bug 670531

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 670531
6 years ago
6 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
STR:
 1. Load http://www.mozilla.org/about/policies/privacy-policy.html?a=b
 2. Ctrl-L to focus URLbar, rightarrow to un-highlight & leave cursor @ end
 3. Backspace 4x, to remove "?a=b" suffix. (or make some other tiny edit)
 4. Ctrl-A, Ctrl-C to copy the resulting URL
 5. Paste somewhere

RESULT: www.mozilla.org/about/policies/privacy-policy.html is pasted (no http://)

Gavin points out in #developers that some edits definitely should prevent the http:// (e.g. replacing your URLbar contents with "g some search terms" + copy --> you don't want to get "http://g some search terms").  However, for small edits, it'd be great if we could make this work...
(Reporter)

Updated

6 years ago
Blocks: 665580
(Reporter)

Updated

6 years ago
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Updated

6 years ago
CCing Dao and Gavin in case they know who works on this feature.
Keywords: regression
Dao and I have worked on this feature.
Isn't it a duplicate of bug 670531 ?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670531
No longer blocks: 665580
You need to log in before you can comment on or make changes to this bug.