Last Comment Bug 671943 - TI+JM: Assertion failure: Unpossible rejoin!, at InvokeHelpers.cpp:1371
: TI+JM: Assertion failure: Unpossible rejoin!, at InvokeHelpers.cpp:1371
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: infer-regress
  Show dependency treegraph
 
Reported: 2011-07-15 13:02 PDT by Jan de Mooij [:jandem]
Modified: 2011-07-16 07:47 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (285 bytes, application/x-javascript)
2011-07-15 13:03 PDT, Jan de Mooij [:jandem]
no flags Details

Description Jan de Mooij [:jandem] 2011-07-15 13:02:29 PDT
$ ./js -m -n -a test.js
Assertion failure: Unpossible rejoin!, at InvokeHelpers.cpp:1371

Revision b769a2b79e6b, 32-bit OS X shell.
Comment 1 Jan de Mooij [:jandem] 2011-07-15 13:03:50 PDT
Created attachment 546214 [details]
Testcase
Comment 2 Brian Hackett (:bhackett) 2011-07-16 07:47:05 PDT
Since we can now discard code during GC, we now need to be able to rejoin from calls that can't change types but do allocate GC things.  Ran across a couple working on the lazy types patch, but should have looked through the rest more thoroughly (did that here).

http://hg.mozilla.org/projects/jaegermonkey/rev/77b0c25be7fb

Note You need to log in before you can comment on or make changes to this bug.