Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Add support for CSS3 Positioned Floats

RESOLVED WONTFIX

Status

()

Core
Layout: Floats
--
enhancement
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: Jose Fandos, Unassigned)

Tracking

({css3})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Add support for positioned floats:

http://www.interoperabilitybridges.com/css3-floats/

http://ie.microsoft.com/testdrive/HTML5/PositionedFloats/Default.html?o=1
I think there are far better approaches to providing new layout capabilities for the Web, such as flexbox and grid.  Those should be higher priorities; I think the positioned floats proposal is a bad idea for numerous reasons.

First, floats are extremely complicated to implement:  even the float features in CSS1 are nowhere close to interoperably implemented across browsers; this complicates them substantially.

Second, floats are not a good technique for layout -- most uses of floats are not what they were designed for -- and when floats are used for layout, they tend to result in pages that are fragile, and don't scale well to different devices (of different sizes, with different fonts, etc.).  I think the positioned floats proposal makes this *substantially* worse; while you can do neat things with the positioned floats proposal, the easy way to do those neat things will most likely result in content that doesn't work across devices.

Therefore I don't think we should implement this proposal.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 674804
You need to log in before you can comment on or make changes to this bug.