nsPluginsDirBeOS.cpp severely needs some TLC

VERIFIED DUPLICATE of bug 68907

Status

()

VERIFIED DUPLICATE of bug 68907
18 years ago
16 years ago

People

(Reporter: bnesse, Assigned: serhunt)

Tracking

({helpwanted})

Trunk
Other
BeOS
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
This file is in need of some attention. It currently does not fill in several 
needed fields and leaks memory like a sieve.
(Reporter)

Comment 1

18 years ago
Created attachment 23991 [details] [diff] [review]
Proposed patch to fix the most egregious issues.
(Reporter)

Comment 2

18 years ago
The proposed patch covers the bulk of the issues. The one remaining issue is that 
I don't know how to retrieve the description information on the BeOS. Someone 
with access to a BeOS box needs to take ownership of this one...
Keywords: helpwanted
(Assignee)

Comment 3

18 years ago
We need somebody BeOS-equipped to verify the changes. I'll be happy to check'em 
in after that.

Comment 4

18 years ago
Hi, I just get plugins work under BeOS. I implemented to read mime types properly in BeOS, 
and some more. I created new bug #68907 and attach a patch. The patch include Brian's fix.

Please see bug #68907.
(Reporter)

Comment 5

18 years ago
Duping bug to 68907 and moving cc's over.


*** This bug has been marked as a duplicate of 68907 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.