Last Comment Bug 672254 - The arrow panel's height should be limited by the screen height.
: The arrow panel's height should be limited by the screen height.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Neil Deakin
:
Mentors:
Depends on:
Blocks: 652115 DownloadsPanel 672365
  Show dependency treegraph
 
Reported: 2011-07-18 10:07 PDT by (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
Modified: 2011-08-11 04:41 PDT (History)
8 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test patch (1.22 KB, patch)
2011-07-18 12:14 PDT, Neil Deakin
mak77: feedback+
Details | Diff | Review
make arrowpanels flexible (3.37 KB, patch)
2011-08-05 12:13 PDT, Neil Deakin
neil: review+
Details | Diff | Review

Description (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-07-18 10:07:20 PDT
(In reply to comment #228)
> The download panel should have scrollbars when there's too much downloads in
> the list. With current tryserver build, if there's too much downloads only
> the 17 first (on a 1920x1200 screen) are reachable.

Thanks for the feedback: this looks like a regression in panels with
type="arrow". They are not limited by the height of the screen, while
normal panels are (though they overlap with the task bar on Windows).
These issues should be looked into by someone familiar with arrow panels.

See comment #230 on bug 567934 for more information: https://bugzilla.mozilla.org/show_bug.cgi?id=564934#c230
Comment 1 :Margaret Leibovic 2011-07-18 10:19:59 PDT
Enn is the person who can help you with this.
Comment 2 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-07-18 10:37:45 PDT
Neil, does this bug give you enough steps to reproduce/describe the issue well enough?
Comment 3 Neil Deakin 2011-07-18 11:48:16 PDT
Do you mean that the panel is cropped at the egde of the screen or that it continues past the end of the screen?

Do you have something in the panel that is scrollable?
Comment 4 Neil Deakin 2011-07-18 12:14:16 PDT
Created attachment 546597 [details] [diff] [review]
test patch

Probably the boxes in the arrowpanel binding just need to be made flexible, such that when the panel is resized because it is too big for the screen, the content will stretch down.

Can you test this patch to see if it works for you?
Comment 5 :Paolo Amadini 2011-07-18 12:21:47 PDT
(In reply to comment #4)
> Can you test this patch to see if it works for you?

I'm rebuilding the patch queue leading to bug 564934 right now, I'll add this
patch and let you know if Jared doesn't beat me to it :-)
Comment 6 :Paolo Amadini 2011-07-18 14:47:14 PDT
This patch solves the issue that's specific to the arrow panels, thanks!

I've filed bug 672365 for the remaining issue with the task bar on Windows,
that affects both normal panels and arrow panels.
Comment 7 Neil Deakin 2011-07-19 05:57:03 PDT
Normal panels should probably appear behind the taskbar as other windows do.

For this specific downloads arrow panel, if it does not have any textboxes or other means of text entry in it, it should be sufficient to use level="top".
Comment 8 :Paolo Amadini 2011-07-19 14:43:57 PDT
(In reply to comment #7)
> For this specific downloads arrow panel, if it does not have any textboxes
> or other means of text entry in it, it should be sufficient to use
> level="top".

This can work for us, making bug 672365 a non-blocking issue in our case.
Thanks for the suggestion!
Comment 9 Marco Bonardo [::mak] 2011-07-28 03:53:50 PDT
Comment on attachment 546597 [details] [diff] [review]
test patch

this solves most issues I saw in a resizeable bookmarks panel, could you get review on it?
Comment 10 Marco Bonardo [::mak] 2011-08-02 05:21:50 PDT
Neil, I guess is ok to assign this to you since it has a patch
Comment 11 Neil Deakin 2011-08-05 12:13:00 PDT
Created attachment 551110 [details] [diff] [review]
make arrowpanels flexible
Comment 12 Mounir Lamouri (:mounir) 2011-08-11 04:41:14 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/968dee8a144a

Note You need to log in before you can comment on or make changes to this bug.