Last Comment Bug 672511 - Morph nsIAccessNode::uniqueId
: Morph nsIAccessNode::uniqueId
Status: RESOLVED FIXED
[bk1]
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Atul Aggarwal
:
: alexander :surkov
Mentors:
Depends on:
Blocks: cleanxpcoma11y
  Show dependency treegraph
 
Reported: 2011-07-19 08:09 PDT by alexander :surkov
Modified: 2011-12-01 03:58 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.20 KB, patch)
2011-11-28 19:48 PST, Atul Aggarwal
surkov.alexander: review+
Details | Diff | Splinter Review
Patch v1.01 (2.91 KB, patch)
2011-11-30 00:46 PST, Atul Aggarwal
no flags Details | Diff | Splinter Review
Patch v1.02 (2.91 KB, patch)
2011-11-30 00:49 PST, Atul Aggarwal
no flags Details | Diff | Splinter Review

Description alexander :surkov 2011-07-19 08:09:40 PDT
I realize uniqueId can be interesting for automated testing so it makes sense to keep it. But then it should be scriptable. We could cast void* to int to workaround it.
Comment 1 Trevor Saunders (:tbsaunde) 2011-07-22 21:00:35 PDT
(In reply to comment #0)
> I realize uniqueId can be interesting for automated testing so it makes
> sense to keep it. But then it should be scriptable. We could cast void* to

do we want to use it in our tests? or who do  we expect to be writing tests that want this?

> int to workaround it.

that won't work on 64 bbit platforms.   since all current machines have atmost a 48 bit virtual address psace afaik we ight be able to use a double, I'm not sure if there will be any colisions or not.  Otherwise I suppose we could return 2 ints.
Comment 2 alexander :surkov 2011-07-22 21:21:19 PDT
(In reply to comment #1)
> (In reply to comment #0)
> > I realize uniqueId can be interesting for automated testing so it makes
> > sense to keep it. But then it should be scriptable. We could cast void* to
> 
> do we want to use it in our tests? or who do  we expect to be writing tests
> that want this?

Yes, in out tests.

> > int to workaround it.
> 
> that won't work on 64 bbit platforms.   since all current machines have
> atmost a 48 bit virtual address psace afaik we ight be able to use a double,
> I'm not sure if there will be any colisions or not.  Otherwise I suppose we
> could return 2 ints.

MSAA expects for 32bit, when we do this then int works.
Comment 3 alexander :surkov 2011-08-01 23:03:17 PDT
Ok, it's worth to remove this method at all. Internal part use address as ID, MSAA likely will have own implementation. No tests as far as we have. If we need it then it can be added later.
Comment 4 David Bolter [:davidb] 2011-11-01 07:38:48 PDT
So we want to remove the method right? Good first bug?
Comment 5 alexander :surkov 2011-11-01 08:23:11 PDT
(In reply to David Bolter [:davidb] from comment #4)
> So we want to remove the method right? Good first bug?

yes, if we are agree on comment #3.
Comment 6 Atul Aggarwal 2011-11-28 19:48:35 PST
Created attachment 577470 [details] [diff] [review]
Patch v1
Comment 7 alexander :surkov 2011-11-30 00:01:17 PST
Comment on attachment 577470 [details] [diff] [review]
Patch v1

Review of attachment 577470 [details] [diff] [review]:
-----------------------------------------------------------------

you should bump interface uuid, r=me
Comment 8 Atul Aggarwal 2011-11-30 00:46:08 PST
Created attachment 577888 [details] [diff] [review]
Patch v1.01
Comment 9 Atul Aggarwal 2011-11-30 00:49:22 PST
Created attachment 577889 [details] [diff] [review]
Patch v1.02
Comment 10 alexander :surkov 2011-11-30 00:58:29 PST
Thank you for fixing it.

https://hg.mozilla.org/integration/mozilla-inbound/rev/cacd0273ca21
Comment 11 Marco Bonardo [::mak] 2011-12-01 03:58:11 PST
https://hg.mozilla.org/mozilla-central/rev/cacd0273ca21

Note You need to log in before you can comment on or make changes to this bug.