Control+W does not close tab on http://french.typeit.org

VERIFIED DUPLICATE of bug 380637

Status

()

Core
Keyboard: Navigation
--
major
VERIFIED DUPLICATE of bug 380637
7 years ago
5 years ago

People

(Reporter: Nicolas Barbulesco, Unassigned)

Tracking

1.9.2 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Firefox Windows 3.0.1.

I create a tab.
I go to the Web address french.typeit.org .
I press Control W.
The tab must close. It doesn't. I am OK for a dialog "OK to lose your text?" and requiring a yes and then closing. But, currently, nothing happens, no dialog, no closing.

Thanks for fixing this bug.

Nicolas
Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110720 Firefox/8.0a1

I can confirm that is not possible to close the tab for the page french.typeit.org by pressing CTRL+W. But also, this behavior is encountered on several browsers (IE8, Safari 5.0, Opera 11.10). IMO this issue is web site related.
(Reporter)

Comment 2

7 years ago
The issue is Web page related.
The bug lies in the Web browser. The Web browser is responsible for processing the standard key combination.

Comment 3

7 years ago
Reproduced:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18
Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a2) Gecko/20110720 Firefox/7.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110721 Firefox/8.0a1

Works for me:
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.112 Safari/534.30
OS: Windows XP → All
Hardware: x86 → All
Summary: On Windows, Control W does not close tab. On Windows, Control W does not close tab. → Control+W does not close tab on http://french.typeit.org Control+W does not close tab on http://french.typeit.org
Version: unspecified → Trunk

Comment 4

7 years ago
I can reproduce on FF5, Win XP.
When the focus and cursor is inside the textarea, the element is intercepting the Ctrl+W hotkey. Probably via javascript. It also catches other hotkeys, try e.g. Ctrl+U, press it repeatedly and see it is toggling between various accents above 'u' character.

But maybe this is done in FF by design and javascript is allowed to intercept the keys.
Status: UNCONFIRMED → NEW
Component: General → Keyboard: Navigation
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → keyboard.navigation
Version: Trunk → 1.9.2 Branch
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380637

Updated

7 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

6 years ago
(In reply to Nicolas Barbulesco from comment #0)

(In reply to Nicolas Barbulesco from comment #2)

The same goes for Ctrl L.
(Reporter)

Comment 7

6 years ago
(In reply to Nicolas Barbulesco from comment #6)

> (In reply to Nicolas Barbulesco from comment #0)
> 
> (In reply to Nicolas Barbulesco from comment #2)
> 
> The same goes for Ctrl L.

When I am in the text area, the same, with variants, goes for Ctrl A and Ctrl C. Ctrl A does not select all, but writes some text. Ctrl C, when nothing is selected, writes some text.
Although right-clicking in the text area gives me the contextual menu with "Select all" and "Copy".
(Reporter)

Comment 8

5 years ago
I encounter the same bug in Firefox 16.0.2 on Linux.
(Reporter)

Updated

5 years ago
Blocks: 86194

Updated

5 years ago
No longer blocks: 86194
You need to log in before you can comment on or make changes to this bug.