default/pref/mailnews.js missing pref mail.content_disposition_type

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: K Chayka, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
win32 build 2001012504, but this goes way back...

From what I understand, default/pref/mailnews.js should contain all prefs for
mail-news.

pref("mail.content_disposition_type", n);  (n = whatever the default s/b)
is missing from this file. The only reference there seems to be for this pref is
bug 20655.
good catch.  it got removed from all.js at some point (not sure when).

I'll add it back, defaulted as 0.

patching coming, ducarroz can you review?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Created attachment 24055 [details] [diff] [review]
fix, please review.
Created attachment 24056 [details] [diff] [review]
complete patch, which shows why it was working without a default value (we never checked the return value of the GetIntPref() call)
(Reporter)

Comment 4

17 years ago
Just to make sure...
content_disposition_type = 0 is inline
content_disposition_type = 1 is attachment

and there aren't any other choices.  Correct?
looking at the source, it looks like a value of 2 is possible,

http://lxr.mozilla.org/seamonkey/source/mailnews/compose/src/nsMsgCompUtils.cpp#910

perhaps ducarroz can explain?
fixed.

ducarroz, can you add a comment to mailnews.js to explain what the possible
values of "mail.content_disposition_type" do?
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
For what I can read in the source, a value of 2 means set content-disposition to
attachment only if the content-type of file extension is text.
VERIFIED. pref("mail.content_disposition_type", 0); is present as the last line
in mailnews.js.  
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.