Open Bug 672608 Opened 12 years ago Updated 6 months ago

301 redirect no longer working properly when using www. prefix


(Firefox :: General, defect)

5 Branch
Windows Vista





(Reporter: nrn628, Unassigned)




User Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

I recently upgraded to ff 5.0.1

Actual results:

I noticed that the 301 redirect of the htaccess file of my website no longer worked properly, but instead always redirected to the same (ie wrong) webpage regardless of what was written in the htaccess file.

Expected results:

After investigation with my web host who did not find anything wrong, I discovered that when I did not use the www. prefix the redirect worked ok, but with the prefix it did not, but it worked perfectly either way in internet explorer, and so I was able to conclude that this is a bug in ff 5.
Do you have an URL that demonstrates the problem?
OS: Other → Windows Vista
Hardware: All → x86
Received in private mail: is supposed to redirect to /parshas/Mattos.html
but in my browser it always redirects to /parshas/Pinchos.html, even after I cleared all the cookies.

Only without the prefix does it redirect correctly, and it works fine in ie with the prefix.

Thank you.

Works for me:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv: Gecko/20110614 Firefox/3.6.18
Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a2) Gecko/20110719 Firefox/7.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110719 Firefox/8.0a1
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.112 Safari/534.30
Lynx/2.8.8dev.9 libwww-FM/2.14 SSL-MM/1.4.1 GNUTLS/2.10.5

Does the issue still occur if you start Firefox in Safe Mode?
301 redirects are cached depending on the http headers.
>but in my browser it always redirects to /parshas/Pinchos.html, even after I cleared all the cookies.

cookies have nothing to do with a simple 301/302 redirect. YOu have to clear the disk cache.
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.