Fix double border and box-shadow on panels with -moz-appearance: -moz-win-glass

RESOLVED DUPLICATE of bug 458864

Status

()

RESOLVED DUPLICATE of bug 458864
7 years ago
7 years ago

People

(Reporter: fryn, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
<xul:panels/> that use -moz-appearance: -moz-win-glass (or -moz-win-borderless-glass) seem to be drawing both the rounded glass border and corresponding box-shadow and a rectangular border and corresponding box-shadow in the lower right of the panel. I'm seeing this in my patch for bug 455694 (tab animations). I'll upload a screenshot shortly.
(Reporter)

Comment 1

7 years ago
Created attachment 547000 [details]
screenshot of bug

This is a screenshot of a <xul:panel/> with -moz-appearance: -moz-win-borderless-glass.

Notice the double box shadow along the bottom and right edges of the panel and its unrounded bottom-right corner.

Updated

7 years ago
No longer blocks: 455694
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458864
You need to log in before you can comment on or make changes to this bug.