Last Comment Bug 672758 - make -C [browser|xulrunner]/installer fails
: make -C [browser|xulrunner]/installer fails
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 655678
  Show dependency treegraph
 
Reported: 2011-07-20 04:31 PDT by Jacek Caban
Modified: 2011-07-22 14:20 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (1.31 KB, patch)
2011-07-20 04:31 PDT, Jacek Caban
mh+mozilla: review-
Details | Diff | Splinter Review
Properly set GENERATE_CACHE in all cases (1019 bytes, patch)
2011-07-20 05:00 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Jacek Caban 2011-07-20 04:31:29 PDT
Created attachment 547030 [details] [diff] [review]
fix v1.0

I've found the problem by trying to do |make -C xulrunner/installer| in my cross compiled mingw build on Linux, but after analyzing the problem, it seems to be a problem also for browser builds and other configs. The error message is:

/bin/sh: 1: command not found

That's because GENERATE_CACHE is used as a command in toolkit/mozapps/installer/packager.mk PACK_OMNIJAR rule:

PACK_OMNIJAR    = \
  rm -f omni.jar components/binary.manifest && \
  grep -h '^binary-component' components/*.manifest > binary.manifest ; \
  for m in components/*.manifest; do \
    sed -e 's/^binary-component/\#binary-component/' $$m > tmp.manifest && \
    mv tmp.manifest $$m; \
  done; \
  $(ZIP) -r9m omni.jar $(OMNIJAR_FILES) -x $(NON_OMNIJAR_FILES) && \
  $(GENERATE_CACHE) && \
  $(OPTIMIZE_JARS_CMD) --optimize $(JARLOG_DIR_AB_CD) ./ ./ && \
  mv binary.manifest components && \
  printf "manifest components/binary.manifest\n" > chrome.manifest

but it's set to 1 instead of true in browser/installer/Makefile.in and xulrunner/installer/Makefile.in.
Comment 1 Mike Hommey [:glandium] 2011-07-20 05:00:03 PDT
Created attachment 547037 [details] [diff] [review]
Properly set GENERATE_CACHE in all cases
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-07-21 06:58:43 PDT
Comment on attachment 547037 [details] [diff] [review]
Properly set GENERATE_CACHE in all cases

Review of attachment 547037 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Mike Hommey [:glandium] 2011-07-22 01:25:22 PDT
Fixup:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3223495dfc69

Note You need to log in before you can comment on or make changes to this bug.