Closed Bug 672779 Opened 9 years ago Closed 9 years ago

Fennec displays checkerboard after switching between portrait/landscape mode

Categories

(Firefox for Android Graveyard :: General, defect, P1)

ARM
Android
defect

Tracking

(fennec8+)

RESOLVED DUPLICATE of bug 673122
Tracking Status
fennec 8+ ---

People

(Reporter: anamaria.moldovan, Assigned: stechz)

Details

Attachments

(1 file)

Attached image Page doesnt resize.
Build Id: 
Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110720 Firefox/8.0a1 Fennec/8.0a1 

Device: HTC Desire Z (Android 2.2), LG Optimus 2X (Android 2.2)

Steps to reproduce:
1. In portrait mode, visit a web page (mobile version): e.g.: www.cnn.com
2. Rotate the device again into landscape mode.

Actual results: 
The page doesn't re-size. Please see the attached screenshot.

Expected results:
The browser and page should re-size to fit the orientation of the screen. 

Note: This happens only for the mobile versions of the pages. For the desktop versions it work fine.
Is this a regression? If so we need the range.
tracking-fennec: --- → ?
The last build on which works fine:  
Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110719 Firefox/8.0a1 Fennec/8.0a1  

The build with issues: 
Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110720 Firefox/8.0a1 Fennec/8.0a1 

Built fro: http://hg.mozilla.org/mozilla-central/rev/953f9620f395
Assignee: nobody → wjohnston
tracking-fennec: ? → 8+
I see the checkerboard when refreshing, more the once, http://m.nypost.com/ in portrait mode, is it related? or it's something else and I should file a new bug?
Summary: Fennec not re-sized correctly after switching between portrait/landscape mode on mobile webpages. → Fennec displays checkerboard after switching between portrait/landscape mode
This issue doesn't occur on:
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110719 Firefox/8.0a1 Fennec/8.0a1 
http://hg.mozilla.org/mozilla-central/rev/a666b4f809f0

but it occurs on:
Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110720 Firefox/8.0a1 Fennec/8.0a1 
http://hg.mozilla.org/mozilla-central/rev/953f9620f395

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a666b4f809f0&tochange=953f9620f395
Ben - another high priority bug. Dupe of bug 673122?
Assignee: wjohnston → ben
Priority: -- → P1
Probably.
Try run for cb6f9a2d4f17 is complete.
Detailed breakdown of the results available here:
    http://tbpl.mozilla.org/?tree=Try&rev=cb6f9a2d4f17
Results (out of 10 total builds):
    exception: 1
    success: 9
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/bstover@mozilla.com-cb6f9a2d4f17
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 673122
You need to log in before you can comment on or make changes to this bug.