Closed Bug 672852 Opened 10 years ago Closed 10 years ago

[10.7] Firefox Crash [@ CoreFoundation@0x878a ]

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Seen while looking at 10.7 crash stats. Signature appears on both Firefox 5 and more frequently on the trunk.  https://crash-stats.mozilla.com/report/list?signature=CoreFoundation@0x878a

https://crash-stats.mozilla.com/report/index/1837a6f2-ca40-47e4-a12e-7e5642110719

Frame 	Module 	Signature [Expand] 	Source
0 	CoreFoundation 	CoreFoundation@0x878a 	
1 	XUL 	nsPluginInstanceOwner::~nsPluginInstanceOwner 	nsCoreAnimationSupport.h:114
2 	XUL 	nsPluginInstanceOwner::Release 	dom/plugins/base/nsPluginInstanceOwner.cpp:390
3 	XUL 	nsStopPluginRunnable::~nsStopPluginRunnable 	
4 	XUL 	nsRunnable::Release 	obj-firefox/x86_64/xpcom/build/nsThreadUtils.cpp:55
5 	XUL 	nsThread::ProcessNextEvent 	
6 	XUL 	NS_ProcessPendingEvents_P 	obj-firefox/x86_64/xpcom/build/nsThreadUtils.cpp:195
7 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:130
8 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:422
9 	CoreFoundation 	CoreFoundation@0x12240 	
10 	CoreFoundation 	CoreFoundation@0x11aac 	
11 	CoreFoundation 	CoreFoundation@0x388d8 	
12 	CarbonCore 	CarbonCore@0x17b9b 	
13 	libsystem_c.dylib 	libsystem_c.dylib@0x6b02e 	
14 	CoreFoundation 	CoreFoundation@0x8903 	
15 	CoreFoundation 	CoreFoundation@0x2754 	
16 	libobjc.A.dylib 	libobjc.A.dylib@0xea22 	
17 	CoreFoundation 	CoreFoundation@0xee1f
There are 34 of these across all versions for the past 2 weeks (pre-10.7 release).
I looked through some of these. Some, but not all, were caused by bug 672361. These types of error seems to be caused by bad memory management such as incorrect free calls.
Actually all of the 8.0a1 were caused by bug 672361.
Depends on: 672361
Patch for bug 672361 in nighties from 2011-07-20. Will wait a few days to see if we get any report with build from that date forward before closing.
2011-07-21*
Since the crash went away on the trunk I guess we can resolve this, but ther are still crashes that remain on 5.0.x and 4.0.x.
There have been no crashes since four weeks.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.