Last Comment Bug 672980 - Macro name in AC_DEFUN should be quoted
: Macro name in AC_DEFUN should be quoted
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 All
: -- normal (vote)
: mozilla8
Assigned To: Hiroyuki Ikezoe (:hiro)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-20 16:00 PDT by Hiroyuki Ikezoe (:hiro)
Modified: 2011-08-10 08:57 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
A patch (6.40 KB, patch)
2011-07-20 16:00 PDT, Hiroyuki Ikezoe (:hiro)
ted: review+
Details | Diff | Splinter Review
patch v2 (10.33 KB, patch)
2011-08-09 14:27 PDT, ABE Hiroki (:hATrayflood)
bugspam.Callek: feedback+
Details | Diff | Splinter Review

Description Hiroyuki Ikezoe (:hiro) 2011-07-20 16:00:39 PDT
Created attachment 547280 [details] [diff] [review]
A patch

Macro name in AC_DEFUN should be quoted.
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-07-21 09:14:29 PDT
Comment on attachment 547280 [details] [diff] [review]
A patch

Why is this important? Unless you're worried about multiple inclusion of these files in a way that would cause us to expand it the second time...
Comment 2 Hiroyuki Ikezoe (:hiro) 2011-07-21 16:21:41 PDT
Actually it is not so important now but I suppose it might have to be changed in the future.

Please see http://sources.redhat.com/automake/automake.html#Extending-aclocal
Comment 4 Mounir Lamouri (:mounir) 2011-08-09 05:53:00 PDT
Backed-out from inbound due to a perma-orange, see:
http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642

The patch in this bug might not bee related, the entire push has been backed out.
Comment 5 ABE Hiroki (:hATrayflood) 2011-08-09 07:43:54 PDT
(In reply to Mounir Lamouri (:volkmar) from comment #4)
> Backed-out from inbound due to a perma-orange, see:
> http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642
> 
> The patch in this bug might not bee related, the entire push has been backed
> out.

maybe, this perma-orange is caused by difference between /js/src/build/autoconf/*.m4 and /build/autoconf/*.m4 .
/js/src/build/autoconf/*.m4 should be identical /build/autoconf/*.m4 .
Comment 6 Justin Wood (:Callek) 2011-08-09 07:48:28 PDT
(In reply to ABE Hiroki (hATrayflood) from comment #5)
> (In reply to Mounir Lamouri (:volkmar) from comment #4)
> > Backed-out from inbound due to a perma-orange, see:
> > http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642
> > 
> > The patch in this bug might not bee related, the entire push has been backed
> > out.
> 
> maybe, this perma-orange is caused by difference between
> /js/src/build/autoconf/*.m4 and /build/autoconf/*.m4 .
> /js/src/build/autoconf/*.m4 should be identical /build/autoconf/*.m4 .

That is exactly it, if you can upload a new patch (carry forward the r+) just copying the build/autoconf/*.m4 to the js/src/build/autoconf... I can reland within the next 24 hours for you.
Comment 7 ABE Hiroki (:hATrayflood) 2011-08-09 08:01:53 PDT
(In reply to Justin Wood (:Callek) from comment #6)
> (In reply to ABE Hiroki (hATrayflood) from comment #5)
> > (In reply to Mounir Lamouri (:volkmar) from comment #4)
> > > Backed-out from inbound due to a perma-orange, see:
> > > http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642
> > > 
> > > The patch in this bug might not bee related, the entire push has been backed
> > > out.
> > 
> > maybe, this perma-orange is caused by difference between
> > /js/src/build/autoconf/*.m4 and /build/autoconf/*.m4 .
> > /js/src/build/autoconf/*.m4 should be identical /build/autoconf/*.m4 .
> 
> That is exactly it, if you can upload a new patch (carry forward the r+)
> just copying the build/autoconf/*.m4 to the js/src/build/autoconf... I can
> reland within the next 24 hours for you.

sorry, I can't upload a new patch. I'm out now, so I don't have build environment here.

Ikezoe-san: Can you followup this patch ?
Comment 8 ABE Hiroki (:hATrayflood) 2011-08-09 14:27:41 PDT
Created attachment 551887 [details] [diff] [review]
patch v2

patch v2.
fix perma-orange http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642
Comment 9 Hiroyuki Ikezoe (:hiro) 2011-08-09 14:49:41 PDT
(In reply to ABE Hiroki (hATrayflood) from comment #8)
> Created attachment 551887 [details] [diff] [review] [diff] [details] [review]
> patch v2
> 
> patch v2.
> fix perma-orange
> http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642

Wow! Thank you so much!

I did not know existence of check-sync-dirs.py! I am sorry and thank you!
Comment 10 Justin Wood (:Callek) 2011-08-10 00:44:35 PDT
(In reply to Hiroyuki Ikezoe (:hiro) from comment #9)
> (In reply to ABE Hiroki (hATrayflood) from comment #8)
> > Created attachment 551887 [details] [diff] [review]
> > patch v2
> > 
> > patch v2.
> > fix perma-orange
> > http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=0adaae140642
> 
> Wow! Thank you so much!
> 
> I did not know existence of check-sync-dirs.py! I am sorry and thank you!

Even those of us who do know of it, forget it a lot. No big deal.

Relanded as: http://hg.mozilla.org/integration/mozilla-inbound/rev/f95d2c738d52

Note You need to log in before you can comment on or make changes to this bug.