handling of absolute URIs with port numbers

VERIFIED DUPLICATE of bug 51237

Status

()

--
major
VERIFIED DUPLICATE of bug 51237
18 years ago
18 years ago

People

(Reporter: sorin, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have been using several versions of mozilla (M17/M18/0.7) on a Linux RH 6.2
Intel based box.

With all these versions, I have encountered the following strange behaviour: I
am running 2 web servers on my computer, on different ports (servletrunner and a
normal web server, to be precise): say 8080 and 80.

the pages generated by the servletrunner contain absolute URIs to servletrunner,
e.g.:

http://mymachine.mydomain.lu:8080/servlet/myServlet

as long as absolute URIs to the 'normal' web server (images, etc.).

Moreover, the servlet is using the traditional session management of servlets
(cookie based sessions).

when following the links (http://mymachine.mydomaine.lu:8080/servlet/myServlet),
mozilla tries get pages with a very strange pattern:

1st attempt: http://mymachine.mydomaine.lu:8080/servlet/myServlet
2nd attempt: http://mymachine.mydomaine.lu:80/servlet/myServlet
3rd attempt: http://mymachine.mydomaine.lu:80/servlet/myServlet

and the 4th attempt loops, meaning it really gets the correct URI this time.

the funny thing is that the web server on port 80 is also running JServe, so
that the second (and third) attempts are successful. However, session is
naturally lost in that case, since the cookie is not sent to port 80.

Comment 1

18 years ago
*** Bug 67302 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Dup of bug 51237 "Mozilla confuses multiple ports on same machine"
Adding comment there about your observations - they look interesting.

*** This bug has been marked as a duplicate of 51237 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
VERIFIED dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.