Closed Bug 673065 Opened 10 years ago Closed 10 years ago

Browser does not list the usernames when logging in to a http auth protected website

Categories

(Firefox :: General, defect)

5 Branch
All
Other
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 227632

People

(Reporter: bcraigie, Unassigned)

Details

Attachments

(1 file)

Attached image browser_auth.jpg
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

When I try to log in to a secure (https) password protected website such as https://www.123-reg.co.uk/secure/index.cgi the browser prompts for the username and password.  If I have been there before and chosen to "remember password" it only comes up with the first one I remembered despite the browser having remembered several different username/password combinations for this site.


Actual results:

Despite the password being remembered, I still need to type in the username and password if I want to log in with a username other than the first one it remembered.


Expected results:

It should have given a password dialog where the username is a drop-down box list of remembered usernames (that also accepts typing of a new username).  When the username is selected from the drop-down, the password that has already been remembered should fill in to the password input box.

Without this new dialog box, you have to type the username and password yourself.  If you have forgotten the password, you can find it from the password manager, but that takes extra time and seems pointless when the browser has the capability of doing that for you.

:-)
If you type the username in a regular testfield in a HTML form (not the HTTP Auth popup), then you have a drop-down list, but not inside the dialog box.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 227632
Thanks Jo, but the website does not give a username in an html form, so your comment is meaningless.
I explained why there was no dropdown button, even though the backend code exists for it. Bug 227632 will fix that.
Ah! Thank you.  Sorry I misunderstood what you had meant. :-)
You need to log in before you can comment on or make changes to this bug.