Last Comment Bug 673072 - Firefox doesn't build with libcurl >= 7.21.7
: Firefox doesn't build with libcurl >= 7.21.7
Status: RESOLVED FIXED
fixed-in-bs
:
Product: Toolkit
Classification: Components
Component: Breakpad Integration (show other bugs)
: Trunk
: All Other
: -- normal (vote)
: ---
Assigned To: Evan Shaw
:
: Ted Mielczarek [:ted.mielczarek]
Mentors:
: 680370 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-21 02:28 PDT by Evan Shaw
Modified: 2011-08-19 01:38 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
First proposed patch - removes references to curl/types.h (2.42 KB, patch)
2011-07-21 02:32 PDT, Evan Shaw
ted: review+
Details | Diff | Splinter Review

Description Evan Shaw 2011-07-21 02:28:08 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110619060346

Steps to reproduce:

Tried to build Firefox:
make -f client.mk


Actual results:

The build failed with the following error:
In file included from /home/evan/projects/mozilla-central/toolkit/crashreporter/google-breakpad/src/common/linux/http_upload.cc:36:0:
../../../../../../dist/system_wrappers/curl/types.h:3:29: fatal error: curl/types.h: No such file or directory
compilation terminated.

This header no longer exists in libcurl 7.21.7. It has been deprecated and empty since curl 7.12.0 (released June 2, 2004).

See these commits:
curl/types.h is deprecated and stubbed out:
https://github.com/bagder/curl/commit/ffc5fa3a2be787c8198eb68836a45c440876c1bd

curl/types.h is removed:
https://github.com/bagder/curl/commit/2ef7a28a71f819343afefa721e5497119fb2cee0


Expected results:

The build succeeds.
Comment 1 Evan Shaw 2011-07-21 02:32:43 PDT
Created attachment 547353 [details] [diff] [review]
First proposed patch - removes references to curl/types.h

The attached patch removes references to curl/types.h. If we still need to be able to build against libcurl versions older than 7.12.0, then I can try a different approach.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-07-21 10:18:46 PDT
Comment on attachment 547353 [details] [diff] [review]
First proposed patch - removes references to curl/types.h

This should be fine. Breakpad only dates back to 2006 anyway. I'll land the Breakpad changes upstream in the Breakpad SVN repository for you.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-07-21 10:28:51 PDT
I pushed this change to the build-system branch:
http://hg.mozilla.org/projects/build-system/rev/aa5bfc851c35

We periodically merge with the mozilla-central branch, someone will update this bug to mark it FIXED when that happens.

Thanks for the patch!
Comment 4 Ted Mielczarek [:ted.mielczarek] 2011-07-21 10:46:04 PDT
Pushed to upstream:
http://code.google.com/p/google-breakpad/source/detail?r=814

We're far enough out of sync with upstream that only one removal applied, upstream has imported its own local copy of curl headers (I think because curl headers are arch-specific for some reason).
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-22 07:02:33 PDT
http://hg.mozilla.org/mozilla-central/rev/aa5bfc851c35
Comment 6 Mike Hommey [:glandium] 2011-08-19 01:38:40 PDT
*** Bug 680370 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.