Last Comment Bug 673228 - Use MOZ_ASSERT instead of NS_ASSERTION in TimeStamp.h
: Use MOZ_ASSERT instead of NS_ASSERTION in TimeStamp.h
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on: 673226
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-21 13:58 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2011-08-25 18:42 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use MOZ_ASSERT instead of NS_ASSERTION in TimeStamp.h (5.69 KB, patch)
2011-07-21 13:58 PDT, Jeff Muizelaar [:jrmuizel]
roc: review+
cjones.bugs: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2011-07-21 13:58:50 PDT
Created attachment 547504 [details] [diff] [review]
Use MOZ_ASSERT instead of NS_ASSERTION in TimeStamp.h

This is helpful because we can potentially get breakpad stacks which would include line numbers. This would be helpful for getting more information for bug 673226.
Comment 1 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-07-21 14:35:39 PDT
Comment on attachment 547504 [details] [diff] [review]
Use MOZ_ASSERT instead of NS_ASSERTION in TimeStamp.h

Review of attachment 547504 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 2 Mounir Lamouri (:mounir) 2011-08-11 04:25:22 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/bf03e8391ff8
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-08-11 06:19:07 PDT
This was backed out.
Comment 4 Ed Morley [:emorley] 2011-08-25 18:42:19 PDT
http://hg.mozilla.org/mozilla-central/rev/625a18d70e9e

Note You need to log in before you can comment on or make changes to this bug.