egrep failures in configure on OS X 10.7

RESOLVED DUPLICATE of bug 655339

Status

defect
RESOLVED DUPLICATE of bug 655339
8 years ago
Last year

People

(Reporter: gps, Unassigned)

Tracking

Trunk
x86_64
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
gps and liuche upgraded our 10.6 MBP's to Lion and are now encountering failures with egrep in configure when writing confdefs.h. egrep fails with "Regular expression too big."

We had built nightly yesterday on 10.6 without issue. Interestingly, others have reported success building on Lion. Also, the version of grep between 10.6 and 10.7 did not change (GNU 2.5.1). And, running the `sort | egrep` manually in an existing bash shell seems to work.

I'm inclined to believe our build environments became busted after the upgrade. But, it would be nice to identify the root cause and resolution in case it impacts others.
Duplicate of Bug 655339. Workaround on comment #21
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 655339

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.