Closed Bug 673300 Opened 10 years ago Closed 7 years ago

Investigate speeding up /tests/dom/tests/mochitest/ajax/offline/test_updatingManifest.html

Categories

(Core :: Networking: Cache, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 892488

People

(Reporter: jgriffin, Assigned: mayhemer)

References

(Blocks 1 open bug)

Details

As part of the BuildFaster project (see https://wiki.mozilla.org/ReleaseEngineering/BuildFaster), we are investigating whether certain slow mochitests can be sped up.

test_updatingManifest.html is a slow test, average execution time on a recent run (in ms):

	win32-debug, 29774
	linux-opt, 21966
	macosx64-debug, 30471
	win32-opt, 22299
	linux64-opt, 21803
	linux64-debug, 27758
	macosx-debug, 30865
	linux-debug, 28561
Honza, as the original test author, would you be willing to see if there is anything that can be done to speed up this test?
Yes, I will check this test.  I think it is based on change in the content driven by Date (actual time) change an we wait for some 10 or 11 seconds, probably even more.

I think we can improve this relatively simply.

-> me
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 892488
You need to log in before you can comment on or make changes to this bug.