Last Comment Bug 673304 - builder.addons.mozilla.org zombie compartment
: builder.addons.mozilla.org zombie compartment
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
:
Mentors:
Depends on: new-web-workers
Blocks: ZombieCompartments
  Show dependency treegraph
 
Reported: 2011-07-21 17:06 PDT by Nicholas Nethercote [:njn]
Modified: 2012-01-14 00:18 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Nicholas Nethercote [:njn] 2011-07-21 17:06:06 PDT
On a recent Linux64 dev build, no add-ons enabled, moderately new profile...

Steps:
- Start Firefox
- open about:memory?verbose
- open https://builder.addons.mozilla.org/addon/1010707/latest/ in a second tab, then close it
- After an hour and many clicks of "minimize memory usage" the compartment is still there:

│  ├───5,437,193 B (08.07%) -- compartment(https://builder.addons.mozilla.org/addon/1010707/latest/)
│  │   ├──3,616,768 B (05.36%) -- gc-heap
│  │   │  ├──1,745,488 B (02.59%) -- arena-unused
│  │   │  ├──1,120,296 B (01.66%) -- objects
│  │   │  ├────670,208 B (00.99%) -- shapes
│  │   │  ├─────47,488 B (00.07%) -- arena-padding
│  │   │  ├─────21,192 B (00.03%) -- arena-headers
│  │   │  ├─────12,096 B (00.02%) -- strings
│  │   │  └──────────0 B (00.00%) -- xml
│  │   ├────898,169 B (01.33%) -- scripts
│  │   ├────589,824 B (00.87%) -- mjit-code
│  │   ├────204,144 B (00.30%) -- tjit-data
│  │   │    ├──148,000 B (00.22%) -- allocators-reserve
│  │   │    └───56,144 B (00.08%) -- allocators-main
│  │   ├────116,864 B (00.17%) -- object-slots
│  │   ├─────11,424 B (00.02%) -- string-chars
│  │   ├──────────0 B (00.00%) -- mjit-data
│  │   └──────────0 B (00.00%) -- tjit-code
Comment 1 Andrew McCreight [:mccr8] 2011-07-21 17:12:46 PDT
Happens to me, too, on a Mac, with a few non-threatening addons and a super old profile.  Though I only waited a few minutes because I am impatient.  Similar memory profile.
Comment 2 Alon Zakai (:azakai) 2011-07-27 16:01:37 PDT
I don't get this leak on a brand new linux32 debug build.

This page uses web workers. So I would like to be optimistic and believe that it is now fixed for the same reason bug 669545 is.
Comment 3 Nicholas Nethercote [:njn] 2011-07-27 16:14:31 PDT
(In reply to comment #2)
> 
> This page uses web workers. So I would like to be optimistic and believe
> that it is now fixed for the same reason bug 669545 is.

I can no longer reproduce on Linux64, so I'm happy to be optimistic as well.

Note You need to log in before you can comment on or make changes to this bug.