Last Comment Bug 673390 - Crash on Linux [@ nsNativeTheme::IsIndeterminateProgress]
: Crash on Linux [@ nsNativeTheme::IsIndeterminateProgress]
Status: RESOLVED FIXED
[inbound]
: crash, testcase
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: x86_64 Linux
: -- critical (vote)
: mozilla8
Assigned To: arno renevier
:
Mentors:
Depends on:
Blocks: randomstyles
  Show dependency treegraph
 
Reported: 2011-07-22 05:16 PDT by Jesse Ruderman
Modified: 2011-08-05 08:47 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (crashes Firefox when loaded on Linux) (68 bytes, text/html)
2011-07-22 05:16 PDT, Jesse Ruderman
no flags Details
stack trace (9.44 KB, text/plain)
2011-07-22 05:17 PDT, Jesse Ruderman
no flags Details
patch v1 (2.28 KB, patch)
2011-07-23 00:51 PDT, arno renevier
roc: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2011-07-22 05:16:18 PDT
Created attachment 547665 [details]
testcase (crashes Firefox when loaded on Linux)
Comment 1 Jesse Ruderman 2011-07-22 05:17:23 PDT
Created attachment 547666 [details]
stack trace
Comment 2 arno renevier 2011-07-23 00:51:42 PDT
Created attachment 547902 [details] [diff] [review]
patch v1

This happens because as div is fixed, it's parent is a ViewPortFrame which a null content. Then, call to  aFrame->GetContent()->IsHTML(nsWidgetAtoms::progress) crashes mozilla.
Comment 3 arno renevier 2011-07-23 00:57:59 PDT
I've also checked (at least in the gtk port) that there is no other moz-appearance property which exhibits the same bug, but I wonder if it's better, for more safety, to make all methods in nsNativeTheme.cpp handle frames with null content
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-07-31 17:14:53 PDT
Comment on attachment 547902 [details] [diff] [review]
patch v1

Review of attachment 547902 [details] [diff] [review]:
-----------------------------------------------------------------

Lovely!
Comment 5 Marco Bonardo [::mak] 2011-08-05 08:47:21 PDT
http://hg.mozilla.org/mozilla-central/rev/d8a5ef7806ec

Note You need to log in before you can comment on or make changes to this bug.