Closed Bug 673392 Opened 10 years ago Closed 10 years ago

Thunderbird 5 does not show an attachment on a mail when attachment is embedded as Content-Type: application/octet-stream;

Categories

(MailNews Core :: MIME, defect)

All
Other
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 674473

People

(Reporter: franz.brodemeyer, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

I want to open an attachment of an email which sure has one. The attachment is embedded as Content-Type: application/octet-stream; and Thunderbird does not show that there is an attachment on the email. The typical paper clip symbol is missing, also the attachment bar at the bottom of the email preview area is missing. It seems as if the email does not have an attachment, which is not true, when you look into the source code.

It doesn't matter if the attached file is a pdf or another filetype.


Actual results:

I cannot open the attached file.


Expected results:

I should see a paper clip or the attachment bar at the bottom of the preview area in order to open up the attachment.
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 *Firefox*/5.0
Build ID: 20110615151330 ?
In the german Thunderbird board they found out, that this has something to do with the separator.

------=_Part_108_25688070.1309354608047

http://www.thunderbird-mail.de/forum/viewtopic.php?f=31&t=54285&p=290212

When you save the email as an eml file, delete the separators and open it in Thunderbird again, the attachment is shown correctly.
Here is the details on how Outlook 2003 is adds MIME separators. Hopefully someone can use it to diagnose where Thunderbird is getting lost (regardless whether Outlook's output is conforming).

MIME-Version: 1.0
Content-Type: multipart/related;
	boundary="----=_NextPart_000_0038_01CC5812.3E1BB2C0"
X-Mailer: Microsoft Office Outlook 11
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.6109
.
. (more envelope stuff)
.
This is a multi-part message in MIME format.

------=_NextPart_000_0038_01CC5812.3E1BB2C0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_001_0039_01CC5812.3E1BB2C0"
------=_NextPart_001_0039_01CC5812.3E1BB2C0
Content-Type: text/plain;
	charset="us-ascii"
Content-Transfer-Encoding: 7bit
.
. (plaintext email here)
.
------=_NextPart_001_0039_01CC5812.3E1BB2C0
Content-Type: text/html;
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
.
. (HTML formatted email here)
.
------=_NextPart_001_0039_01CC5812.3E1BB2C0--

------=_NextPart_000_0038_01CC5812.3E1BB2C0
Content-Type: application/octet-stream;
	name="Your horoscope.dsx"
Content-Transfer-Encoding: quoted-printable
.
. (attachment #1 [details] [diff] [review]
.
------=_NextPart_000_0038_01CC5812.3E1BB2C0
Content-Type: application/octet-stream;
	name="How it was made.log"
Content-Transfer-Encoding: base64
.
. (attachment #2 [details] [diff] [review])
.
------=_NextPart_000_0038_01CC5812.3E1BB2C0--
Component: General → MIME
Product: Thunderbird → MailNews Core
QA Contact: general → mime
Problem of the mail is not "application/octet-stream" itself.
Real problem of the mail is "the application/octet-stream part is embed in multipart/related"(i.e malformed mail). And, Tb currently ignores such malformed part. (If attachment of mail, it has to be correctly embed in multipart/mixed.)

For such malformed multipart/related mail, enhancement of Tb is already requested.
See Bug 674473.
> Make MIME parts in a multipart/related context that are not referred to
> or cannot be displayed inline available as attachments again

See also Bug 602718.
By enhancement of Bug 602718(available from Tb 8), new "View/Message Body As/All Body Parts" feature will be introduced. You can save your "application/octet-stream part which is incorrectly embed in multipart/related" by the enhancement.
The attachments doesn't visible too, by application/pdf

--0181E6C5DB9CB555ABAA3D804D827A47
Content-Type: application/pdf; name="... 015176.pdf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="... 015176.pdf"

...
Duping to Bug 674473.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 674473
You need to log in before you can comment on or make changes to this bug.