Crashes when trying to send mail from POP account

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: naving, Assigned: bugzilla)

Tracking

({crash})

Trunk
Future
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
NTDLL! 77f7629c()
js_AllocGCThing(JSContext * 0x029438d0, unsigned int 0) line 441 + 41 bytes
js_NewObject(JSContext * 0x029438d0, JSClass * 0x016c1c68 struct JSClass  
KeyEventClass, JSObject * 0x00d57fc8, JSObject * 0x00000000) line 1470 + 11 
bytes
JS_NewObject(JSContext * 0x029438d0, JSClass * 0x016c1c68 struct JSClass  
KeyEventClass, JSObject * 0x00d57fc8, JSObject * 0x00000000) line 1945 + 21 
bytes
NS_NewScriptKeyEvent(nsIScriptContext * 0x02943a80, nsISupports * 0x06911914, 
nsISupports * 0x00000000, void * * 0x0012c59c) line 1014 + 23 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x06911914) line 141 + 25 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x03fd8d50, 
nsIDOMEvent * 0x06911914, nsIDOMEventTarget * 0x0367fdc8, unsigned int 2, 
unsigned int 7) line 838 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x029e2230, nsEvent * 
0x0012cf98, nsIDOMEvent * * 0x0012cd38, nsIDOMEventTarget * 0x0367fdc8, unsigned 
int 7, nsEventStatus * 0x0012cfbc) line 1257 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x0367fdc0, nsIPresContext * 
0x029e2230, nsEvent * 0x0012cf98, nsIDOMEvent * * 0x0012cd38, unsigned int 1, 
nsEventStatus * 0x0012cfbc) line 3455
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x03a30458, 
nsIPresContext * 0x029e2230, nsEvent * 0x0012d2d4, nsIFrame * 0x00e1c200, 
nsEventStatus * 0x0012d23c, nsIView * 0x029e3a90) line 527
PresShell::HandleEventInternal(nsEvent * 0x0012d2d4, nsIView * 0x029e3a90, 
unsigned int 1, nsEventStatus * 0x0012d23c) line 4908 + 43 bytes
PresShell::HandleEvent(PresShell * const 0x029e3364, nsIView * 0x029e3a90, 
nsGUIEvent * 0x0012d2d4, nsEventStatus * 0x0012d23c, int 1, int & 1) line 4849 + 
25 bytes
nsView::HandleEvent(nsView * const 0x029e3a90, nsGUIEvent * 0x0012d2d4, unsigned 
int 28, nsEventStatus * 0x0012d23c, int 1, int & 1) line 372
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x029e3c60, nsGUIEvent * 
0x0012d2d4, nsEventStatus * 0x0012d23c) line 1424
HandleEvent(nsGUIEvent * 0x0012d2d4) line 68
nsWindow::DispatchEvent(nsWindow * const 0x029e3954, nsGUIEvent * 0x0012d2d4, 
nsEventStatus & nsEventStatus_eIgnore) line 687 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012d2d4) line 708
nsWindow::DispatchFocus(unsigned int 108) line 4097 + 15 bytes
nsWindow::ProcessMessage(unsigned int 8, unsigned int 593386, long 0, long * 
0x0012d644) line 3104 + 19 bytes
nsWindow::WindowProc(HWND__ * 0x00a90c6c, unsigned int 8, unsigned int 593386, 
long 0) line 922 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e8a5c0()
USER32! 77e82d7c()
USER32! 77e720ff()
USER32! 77e82832()
USER32! 77e8903f()
USER32! 77e8ad30()
USER32! 77e8b044()
USER32! 77e8aed8()
USER32! 77e8b203()
USER32! 77e8a5a6()
nsDebug::Assertion(const char * 0x066883e8, const char * 0x100d13ec, const char 
* 0x066883b4, int 210) line 213 + 22 bytes
nsDebug::NotReached(const char * 0x066883e8, const char * 0x066883b4, int 210) 
line 412 + 22 bytes
nsPlaintextEditor::~nsPlaintextEditor() line 210 + 21 bytes
nsHTMLEditor::~nsHTMLEditor() line 178 + 123 bytes
nsHTMLEditorLog::~nsHTMLEditorLog() line 52 + 22 bytes
nsHTMLEditorLog::`scalar deleting destructor'() + 15 bytes
nsEditor::Release(nsEditor * const 0x0679d590) line 220 + 158 bytes
nsHTMLEditor::Release(nsHTMLEditor * const 0x0679d590) line 181 + 12 bytes
nsHTMLEditorLog::Release(nsHTMLEditorLog * const 0x0679d590) line 54 + 12 bytes
nsCOMPtr<nsIHTMLEditor>::~nsCOMPtr<nsIHTMLEditor>() line 489
nsEditorShell::~nsEditorShell() line 273 + 163 bytes
nsEditorShell::`scalar deleting destructor'() + 15 bytes
nsEditorShell::Release(nsEditorShell * const 0x067238c0) line 280 + 158 bytes
nsXPCWrappedNative::~nsXPCWrappedNative() line 398 + 27 bytes
nsXPCWrappedNative::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsXPCWrappedNative::Release(nsXPCWrappedNative * const 0x068b8b30) line 71 + 31 
bytes
nsXPCWrappedNative::JSObjectFinalized(JSContext * 0x067487f0, JSObject * 
0x04f0a6b0) line 96
WrappedNative_Finalize(JSContext * 0x067487f0, JSObject * 0x04f0a6b0) line 894
js_FinalizeObject(JSContext * 0x067487f0, JSObject * 0x04f0a6b0) line 1631 + 274 
bytes
js_GC(JSContext * 0x067487f0, unsigned int 0) line 1196 + 11 bytes
js_ForceGC(JSContext * 0x067487f0) line 931 + 11 bytes
js_DestroyContext(JSContext * 0x067487f0, int 2) line 224 + 9 bytes
JS_DestroyContext(JSContext * 0x067487f0) line 885 + 11 bytes
nsJSContext::~nsJSContext() line 389 + 13 bytes
nsJSContext::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsJSContext::Release(nsJSContext * const 0x067489a0) line 397 + 154 bytes
nsCOMPtr<nsIScriptContext>::assign_assuming_AddRef(nsIScriptContext * 
0x00000000) line 471
nsCOMPtr<nsIScriptContext>::assign_with_AddRef(nsISupports * 0x00000000) line 
951
nsCOMPtr<nsIScriptContext>::operator=(nsIScriptContext * 0x00000000) line 583
nsDocShell::Destroy(nsDocShell * const 0x067226c4) line 1726
nsWebShell::Destroy(nsWebShell * const 0x067226c4) line 1446
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame() line 490
nsHTMLFrameInnerFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x04ea3878, nsIPresContext * 0x040d43d0) line 
425 + 34 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x040d43d0) line 36
nsContainerFrame::Destroy(nsContainerFrame * const 0x04e9c3fc, nsIPresContext * 
0x040d43d0) line 98
nsFrameList::DestroyFrames(nsIPresContext * 0x040d43d0) line 36
nsContainerFrame::Destroy(nsContainerFrame * const 0x04e9c36c, nsIPresContext * 
0x040d43d0) line 98
nsBoxFrame::Destroy(nsBoxFrame * const 0x04e9c36c, nsIPresContext * 0x040d43d0) 
line 1013 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x040d43d0) line 36
nsContainerFrame::Destroy(nsContainerFrame * const 0x04e14e5c, nsIPresContext * 
0x040d43d0) line 98
nsBoxFrame::Destroy(nsBoxFrame * const 0x04e14e5c, nsIPresContext * 0x040d43d0) 
line 1013 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x040d43d0) line 36
nsContainerFrame::Destroy(nsContainerFrame * const 0x04e14dcc, nsIPresContext * 
0x040d43d0) line 98
nsBoxFrame::Destroy(nsBoxFrame * const 0x04e14dcc, nsIPresContext * 0x040d43d0) 
line 1013 + 13 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x040d43d0) line 36
nsContainerFrame::Destroy(nsContainerFrame * const 0x04e14d90, nsIPresContext * 
0x040d43d0) line 98
ViewportFrame::Destroy(ViewportFrame * const 0x04e14d90, nsIPresContext * 
0x040d43d0) line 142
FrameManager::~FrameManager() line 409
FrameManager::`scalar deleting destructor'(unsigned int 1) + 15 bytes
FrameManager::Release(FrameManager * const 0x040d5a10) line 388 + 157 bytes
PresShell::~PresShell() line 1324 + 36 bytes
PresShell::`scalar deleting destructor'() + 15 bytes
PresShell::Release(PresShell * const 0x040d4ad0) line 1234 + 158 bytes
nsCOMPtr<nsIPresShell>::~nsCOMPtr<nsIPresShell>() line 489
DocumentViewerImpl::~DocumentViewerImpl() line 464 + 100 bytes
DocumentViewerImpl::`scalar deleting destructor'(unsigned int 1) + 15 bytes
DocumentViewerImpl::Release(DocumentViewerImpl * const 0x040d62c0) line 372 + 
154 bytes
nsCOMPtr<nsIContentViewer>::assign_assuming_AddRef(nsIContentViewer * 
0x00000000) line 471
nsCOMPtr<nsIContentViewer>::assign_with_AddRef(nsISupports * 0x00000000) line 
951
nsCOMPtr<nsIContentViewer>::operator=(nsIContentViewer * 0x00000000) line 583
nsDocShell::Destroy(nsDocShell * const 0x03f95d74) line 1707
nsWebShell::Destroy(nsWebShell * const 0x03f95d74) line 1446
nsXULWindow::Destroy(nsXULWindow * const 0x03f932f4) line 335
nsWebShellWindow::Destroy(nsWebShellWindow * const 0x03f932f4) line 1751 + 9 
bytes
nsChromeTreeOwner::Destroy(nsChromeTreeOwner * const 0x03f95a44) line 224
nsMsgCompose::CloseWindow(nsMsgCompose * const 0x068b50e0) line 729 + 12 bytes
nsMsgComposeSendListener::OnStopCopy(nsMsgComposeSendListener * const 
0x069197e4, unsigned int 0) line 1742
nsMsgComposeAndSend::NotifyListenersOnStopCopy(nsMsgComposeAndSend * const 
0x06919640, unsigned int 0) line 3431
CopyListener::OnStopCopy(CopyListener * const 0x071bce50, unsigned int 0) line 
142
nsMsgCopyService::ClearRequest(nsCopyRequest * 0x071bcdf0, unsigned int 0) line 
160
nsMsgCopyService::NotifyCompletion(nsMsgCopyService * const 0x071bbfe0, 
nsISupports * 0x071b96c0, nsIMsgFolder * 0x029910fc, unsigned int 0) line 495
nsMsgLocalMailFolder::EndCopy(nsMsgLocalMailFolder * const 0x029911b4, int 1) 
line 2380
nsMsgLocalMailFolder::CopyFileMessage(nsMsgLocalMailFolder * const 0x029910fc, 
nsIFileSpec * 0x071b96c0, nsIMessage * 0x00000000, int 0, nsIMsgWindow * 
0x00000000, nsIMsgCopyServiceListener * 0x071bce50) line 1941 + 23 bytes
nsMsgCopyService::DoNextCopy() line 254 + 78 bytes
nsMsgCopyService::DoCopy(nsCopyRequest * 0x071bcdf0) line 174 + 8 bytes
nsMsgCopyService::CopyFileMessage(nsMsgCopyService * const 0x071bbfe0, 
nsIFileSpec * 0x071b96c0, nsIMsgFolder * 0x029910fc, nsIMessage * 0x00000000, 
int 0, nsIMsgCopyServiceListener * 0x071bce50, nsIMsgWindow * 0x00000000) line 
476 + 12 bytes
nsMsgCopy::DoCopy(nsIFileSpec * 0x071b96c0, nsIMsgFolder * 0x029910fc, 
nsIMessage * 0x00000000, int 0, nsIMsgWindow * 0x00000000, nsMsgComposeAndSend * 
0x06919640) line 305 + 67 bytes
nsMsgCopy::StartCopyOperation(nsIMsgIdentity * 0x0410f290, nsIFileSpec * 
0x071b96c0, int 0, nsMsgComposeAndSend * 0x06919640, const char * 0x0012f850, 
nsIMessage * 0x00000000) line 236 + 35 bytes
nsMsgComposeAndSend::StartMessageCopyOperation(nsIFileSpec * 0x071b96c0, int 0, 
char * 0x071bb6c0) line 4186 + 57 bytes
nsMsgComposeAndSend::MimeDoFCC(nsFileSpec * 0x071b45e0, int 0, const char * 
0x04732018, const char * 0x06546a70, const char * 0x06542460) line 4154 + 29 
bytes
nsMsgComposeAndSend::DoFcc() line 3126 + 74 bytes
nsMsgComposeAndSend::DoDeliveryExitProcessing(nsIURI * 0x071b8784, unsigned int 
0, int 0) line 3067 + 8 bytes
nsMsgComposeAndSend::DeliverAsMailExit(nsIURI * 0x071b8784, unsigned int 0) line 
3088
MailDeliveryCallback(nsIURI * 0x071b8784, unsigned int 0, void * 0x06919640) 
line 2648
nsMsgDeliveryListener::OnStopRunningUrl(nsMsgDeliveryListener * const 
0x071b8f80, nsIURI * 0x071b8784, unsigned int 0) line 82 + 21 bytes
nsUrlListenerManager::BroadcastChange(nsIURI * 0x071b8784, nsUrlNotifyType 
nsUrlNotifyStopRunning, unsigned int 0) line 97
nsUrlListenerManager::OnStopRunningUrl(nsUrlListenerManager * const 0x071b8740, 
nsIMsgMailNewsUrl * 0x071b8784, unsigned int 0) line 110 + 18 bytes
nsMsgMailNewsUrl::SetUrlState(nsMsgMailNewsUrl * const 0x071b8784, int 0, 
unsigned int 0) line 112
nsSmtpProtocol::ProcessProtocolState(nsIURI * 0x071b8784, nsIInputStream * 
0x071b9930, unsigned int 313, unsigned int 36) line 1523
nsMsgProtocol::OnDataAvailable(nsMsgProtocol * const 0x071b83d0, nsIChannel * 
0x071b8094, nsISupports * 0x071b8784, nsIInputStream * 0x071b9930, unsigned int 
313, unsigned int 36) line 194 + 32 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x071bb4a0) 
line 160 + 70 bytes
nsStreamObserverEvent::HandlePLEvent(PLEvent * 0x071bb4a4) line 78
PL_HandleEvent(PLEvent * 0x071bb4a4) line 576 + 10 bytes

Comment 1

18 years ago
I just got this on a custom build of the 0.8 branch from 2/12 around 3pm EST. I
checked the sent folder and the message header was listed but the contents would
not display and gave a numeric message (sorry didn't get it).  I sent a followup
'did you get this' mail which _replaced_ the previous message in the sent folder
listing but did display correctly. So in addition to the crash I lost my record
of the mail. I haven't heard back yet on whether the initial message was received.

SendMessage from XUL
GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id3]
attachments =
DetermineHTMLAction: preferFormat = 0, noHtmlRecipients are deer@zoomnet.net

Message Delivery SUCCEEDED!
nsMsgComposeSendListener: Success on the message send operation!
CopyListener::OnStartCopy()
nsMsgComposeSendListener::OnStartCopy()
CopyListener: SUCCESSFUL ON THE COPY OPERATION!
nsMsgComposeSendListener: Success on the message copy operation!

 RECEIVE SaveAndSendProcessDone


ComposeUnload from XUL
###!!! ASSERTION: ~nsTextEditor: 'Not Reached', file d:\projects\mozilla_source\
mozilla\editor\base\nsPlaintextEditor.cpp, line 210
Summary: Crashes when trying to send mail from POP account → Crashes when trying to send mail from POP account

Comment 2

18 years ago
This happens in news posting as well. Same everything. FWIW, I've switched to a 
tip build.
QA Contact: esther → sheelar

Comment 3

18 years ago
This is crashing because of the nsDebug::Assertion problem discussed in bug
54792. Whether the "~nsTextEditor: 'Not Reached'" issue is a real problem I
don't know.
(Assignee)

Comment 4

18 years ago
It's really charshing or just throuwing an Assertion Alert!
(Reporter)

Comment 5

18 years ago
It crashes. However only the debug builds crash and opt build from the same
day never crashes. Any ideas what's going on ?

Comment 6

18 years ago
Navin,
Is this still a problem in debug builds which you initially reported? If not 
please comment or mark w4me.  
(Reporter)

Comment 7

18 years ago
I am not able to reproduce it consistently therefore I would suggest leave it 
open.

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Updated

17 years ago
Keywords: nsenterprise

Comment 8

17 years ago
adding nsenterprise-
Keywords: nsenterprise → nsenterprise-
Target Milestone: --- → Future

Comment 9

17 years ago
Navin, have you reproduced this recently?
(Reporter)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

17 years ago
Marking WFM.

Comment 11

17 years ago
verifying worksforme based on navin's comments below.  Reopen if you see a crash 
sending mail from pop account which I haven't in the recent builds.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.