Last Comment Bug 673674 - Fennec freezes when viewing a non .txt file from disk
: Fennec freezes when viewing a non .txt file from disk
Status: VERIFIED FIXED
: verified-aurora
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 7
Assigned To: Doug Turner (:dougt)
:
Mentors:
Depends on:
Blocks: 610832
  Show dependency treegraph
 
Reported: 2011-07-23 01:17 PDT by Mike Hommey [:glandium]
Modified: 2013-12-10 10:00 PST (History)
8 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
force quit logcat (19.85 KB, text/plain)
2011-07-25 12:42 PDT, Tony Chung [:tchung]
no flags Details
patch v.1 (1.72 KB, patch)
2011-07-26 23:33 PDT, Doug Turner (:dougt)
blassey.bugs: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-07-23 01:17:56 PDT
(This may be related to bug 661978)

- Go to about:sync-log
- Tap on one of the .log files
- Fennec freezes

(tested on a nightly)

I think the same problem may happen for different file types read from other file:///... directory listings (which about:sync-log is, now)
Comment 1 Tony Chung [:tchung] 2011-07-25 12:23:27 PDT
I can reproduce this on Nexus S, 2.3.4.  tapping a log file in about:sync-log will freeze phone, and then throw the force quit activity dialog.  

Working on getting a logcat
Comment 2 Tony Chung [:tchung] 2011-07-25 12:42:07 PDT
Created attachment 548253 [details]
force quit logcat
Comment 3 Philipp von Weitershausen [:philikon] 2011-07-25 15:48:39 PDT
I'm seeing this too, although I remember it used to work when I first landed bug 610832. I wonder if bug 673309 has fixed it (it renamed .log to .txt).
Comment 4 Richard Newman [:rnewman] 2011-07-25 15:50:03 PDT
Confirmed. Fennec nightly lockup clicking log file. Files stored on SD card.
Comment 5 Richard Newman [:rnewman] 2011-07-25 16:04:33 PDT
Sync annoyance indeed resolved by Bug 673309. Fennec bug still remains, so let's leave this open.
Comment 6 Philipp von Weitershausen [:philikon] 2011-07-25 16:06:38 PDT
Thanks for verifying, Tony. Indeed an underlying Fennec issue, presumably with '.log' files. Changing the summary accordingly.
Comment 7 Philipp von Weitershausen [:philikon] 2011-07-26 07:22:40 PDT
Tony, can you confirm that Fennec Aurora is also affected? If so, we should probably land bug 673309 there too to cover for the underlying Fennec issue.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-26 07:28:01 PDT
I t looks like we try to open the *.log files using nsMimeInfo::LaunchWithFile on desktop and android. Desktop works, opening in the a text editor. Android seems to fail, maybe it is not finding an app (intent) that can open log files.
Comment 9 Philipp von Weitershausen [:philikon] 2011-07-26 08:02:11 PDT
(In reply to comment #8)
> I t looks like we try to open the *.log files using
> nsMimeInfo::LaunchWithFile on desktop and android. Desktop works, opening in
> the a text editor.

Except in most cases .log files (much like .txt files) end up being opened by Firefox itself. (Bug 671911 is an exception that we haven't been able to reproduce.)

> Android seems to fail, maybe it is not finding an app
> (intent) that can open log files.

Either that, or it hangs trying to delegate the intent. Failing explicitly with an error message would be better than hanging.
Comment 10 Tony Chung [:tchung] 2011-07-26 16:34:33 PDT
(In reply to comment #7)
> Tony, can you confirm that Fennec Aurora is also affected? If so, we should
> probably land bug 673309 there too to cover for the underlying Fennec issue.

note to self to check this.
Comment 11 Doug Turner (:dougt) 2011-07-26 16:38:42 PDT
couple of problems.  I am glad that we are going to use .txt for the log files, but that doesn't fix the underlying android's problem.  It looks like nsMIMEInfoAndroid needs some love.  we probably should start caching requests to java.  I'll do that work here.
Comment 12 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-07-26 16:41:18 PDT
I was able to open the log file, after long tapping on it, and then saving it to the doc folder.  I was not able to open it from where it resides normally.  

file:///data/data/org.mozilla.fennec/files/mozilla/<profileid>.default/weave/logs/
Comment 13 Tony Chung [:tchung] 2011-07-26 17:18:02 PDT
changing title to non .txt files, as file handler also locks up on other types (.json)
Comment 14 Tony Chung [:tchung] 2011-07-26 17:18:51 PDT
(In reply to comment #10)
> (In reply to comment #7)
> > Tony, can you confirm that Fennec Aurora is also affected? If so, we should
> > probably land bug 673309 there too to cover for the underlying Fennec issue.
> 
> note to self to check this.

and yes, it happens on aurora and nighty also.
Comment 15 Doug Turner (:dougt) 2011-07-26 17:49:42 PDT
tony, yup.  many file extensions lock things up.
Comment 16 Doug Turner (:dougt) 2011-07-26 23:33:16 PDT
Created attachment 548699 [details] [diff] [review]
patch v.1
Comment 17 Brad Lassey [:blassey] (use needinfo?) 2011-07-26 23:45:35 PDT
Comment on attachment 548699 [details] [diff] [review]
patch v.1

Review of attachment 548699 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 20 Aaron Train [:aaronmt] 2011-07-28 09:05:32 PDT
Verified Fixed
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110728 Firefox/8.0a1 Fennec/8.0a1
Comment 21 Richard Newman [:rnewman] 2011-07-28 16:16:18 PDT
Comment on attachment 548699 [details] [diff] [review]
patch v.1

Per LegNeato's comment on Bug 673309, nominating this for Aurora.
Comment 22 christian 2011-08-02 14:51:43 PDT
Comment on attachment 548699 [details] [diff] [review]
patch v.1

Approved for releases/mozilla-aurora
Comment 23 Richard Newman [:rnewman] 2011-08-02 16:21:20 PDT
Pushed to mozilla-aurora:

  http://hg.mozilla.org/releases/mozilla-aurora/rev/4b51e77c121a

/me thinks about which flags to set...
Comment 24 Aaron Train [:aaronmt] 2011-08-03 06:16:33 PDT
Verified Fixed on Aurora

Mozilla/5.0 (Android; Linux armv7l; rv:7.0a2) Gecko/20110803 Firefox/7.0a2 Fennec/7.0a2

Note You need to log in before you can comment on or make changes to this bug.