Closed Bug 673675 Opened 13 years ago Closed 1 year ago

[10.7] browser.gesture.swipe.up and browser.gesture.swipe.down don't work in Lion

Categories

(Core :: Widget: Cocoa, defect)

5 Branch
All
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: scook0+bugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

1. In System Preferences, set the gestures for Mission Control and App Exposé to 4 fingers instead of 3.
2. In Firefox, open any page with a vertical scroll bar.
2. Swipe 3 fingers up or down on the trackpad.


Actual results:

Nothing.


Expected results:

The browser view should jump to the top or bottom of the page, or perform whatever custom action is set in the "browser.gesture.swipe.up" and "browser.gesture.swipe.down" preferences.
OS: Other → Mac OS X
They're disabled on purpose - see bug 613909.
I can't see any connection between bug 613909 and this one.

I had three-finger up/down swipes configured to previous/next tab in Firefox 5 (and earlier), and they worked fine in OS X 10.6. I upgraded to 10.7 today and they stopped working.

I was able to restore three-finger left/right swipes by monkeying around in Trackpad settings and making "Swipe between pages" use three fingers, but I can't seem to get up/down working again.
Bug 668953 is for making left/right swipes work nicely with Lion, but I couldn't find a corresponding bug for up/down.
Bug 613909 disabled the use of the 3-finger vertical swipe for showing/hiding the tab view (replacing them with scroll-to-top and scroll-to-bottom), because people were having troubles with them anyway.

I would reconfigure Mission Control to use 4 fingers swipe, then you should be able to use scroll-to-top and scroll-to-bottom I think. Maybe the OS is still blocking them ?
I think the OS is blocking the three-finger swipe gesture or has changed it. Setting Mission Control to use 4 finger swipes doesn't re-enable the scroll-to-top/bottom behavior.

The new ballistics on the scroll gesture make this to be not so big a deal, however. You can easily scroll a very long page up and down just by rapidly flicking the touch pad.

I'm more interested in restoring three-finger swipe left/right which I had configured to switch tabs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
correction: I was switching history back and forth on three fingers, shift for tabs.
updating the summary so this shows up in OS X 10.7 tracking lists.
Summary: browser.gesture.swipe.up and browser.gesture.swipe.down don't work in OS X 10.7 Lion → [10.7] browser.gesture.swipe.up and browser.gesture.swipe.down don't work in Lion
Shouldn't Firefox support the two finger swipe left/right for history a la Safari instead?
(In reply to comment #8)
> Shouldn't Firefox support the two finger swipe left/right for history a la
> Safari instead?

That's bug 668953. This bug is about customisable three-finger up/down swipes.
(In reply to Stuart Cook from comment #9)
> (In reply to comment #8)
> > Shouldn't Firefox support the two finger swipe left/right for history a la
> > Safari instead?
> 
> That's bug 668953. This bug is about customisable three-finger up/down
> swipes.

Thanks for the link. I was actually replying to robcee: "I'm more interested in restoring three-finger swipe left/right which I had configured to switch tabs." (Probably should have included context, d'oh).
I have enable four finges gestures at System preferences, and three fingers gestures (swipe up, down, left and right) at BetterTouchTool and it works as expected. So probably this bug is not related to a Firefox problem. Maybe the system block the feature and BetterTouchTool is able to unlock it.
(In reply to Jorge R from comment #11)
> I have enable four finges gestures at System preferences, and three fingers
> gestures (swipe up, down, left and right) at BetterTouchTool and it works as
> expected. So probably this bug is not related to a Firefox problem. Maybe
> the system block the feature and BetterTouchTool is able to unlock it.

Yeah, it seems that if you go into BTT and "three-fingers-down" to "three-fingers-down", Firefox once again sees the gesture. Weird.

I had previously been binding "three-fingers-down" to "control-tab", but that suffers from plugin focus issues. It's nice to have a better workaround.
The problem seems to be that Lion assigns a gesture (3 or 4 fingers) to something like Mission Control, but then it doesn't release the newly idle gesture for use elsewhere.
This issue is negated by inertial scrolling - scroll with two fingers with vigor and you'll move within the page very quickly. I would close this as a non-issue.
(In reply to Nick Lowe from comment #15)
> This issue is negated by inertial scrolling - scroll with two fingers with
> vigor and you'll move within the page very quickly. I would close this as a
> non-issue.

The issue is that browser.gesture.swipe.up and browser.gesture.swipe.down don't work, regardless of whether they're bound to "scroll to top/bottom" or not. Inertial scrolling isn't relevant, because bindings that have nothing to do with scrolling still don't work.
Respectfully, I think you're completely missing the point.

The gestures were added to Firefox before Apple implemented inertial scrolling for all multi-touch trackpads in OS X and before Lion which added semantics to those gestures.

The effort required to get to the top or bottom of a large Web page used to be substantial, with intertial scrolling, it's not an issue.

Because Apple are now using these gestures for other, better, purposes, it is not possible to bind them.
I tested three-finger swipes again just now (with BTT disabled), and they now seem to work. I'm not sure if it was a Firefox update or an OS X update that did it, but the upshot is that swipes now seem to work again, at least in Beta 8.0.
I just updated to Lion, and I found that I could do Option+four-finger-swipe-up/down to do home/end.  (It'd be nice if it worked without Option being held down.)  This Option+... doesn't work in other applications, though, so I am not sure if there is a system-wide we can select for swipe up/down to make Firefox fit in with other apps.

In any case, under Lion we should be reversing the default values for browser.gesture.swipe.{up,down}, otherwise they are the opposite of the normal two-finger scrolling direction.
It didn't work initially after the upgrade, but then when i changed the 'swipe between pages' to 'swipe with three fingers', then firefox started recognizing the swipe.up and swipe.down.. (i have Browser:NextTab and Browser:PrevTab)

so happy i could make it to work.. thanks for this thread that somehow helped me try that. 

btw, i don't use BTT, has 'scroll with inertia' (in universal access -> trackpad options).. just in case you want that info.
Severity: normal → S3

Unable to reproduce.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
Component: General → Widget: Cocoa
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.