Last Comment Bug 673685 - unneeded null assignements in nsHTMLCanvasElement.cpp
: unneeded null assignements in nsHTMLCanvasElement.cpp
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: arno renevier
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-23 03:35 PDT by arno renevier
Modified: 2011-08-01 08:07 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.37 KB, patch)
2011-07-23 03:38 PDT, arno renevier
roc: review+
Details | Diff | Review

Description arno renevier 2011-07-23 03:35:28 PDT
Hi,
some null assignments to mCurrentContext are made in case of UpdateContext failure.
Since bug #656215, they are not useful anymore since they are made inside UpdateContext method.
Comment 1 arno renevier 2011-07-23 03:38:21 PDT
Created attachment 547915 [details] [diff] [review]
patch v1
Comment 2 Marco Bonardo [::mak] 2011-08-01 08:07:24 PDT
http://hg.mozilla.org/mozilla-central/rev/890a3fb12914

Note You need to log in before you can comment on or make changes to this bug.