Bcc: field doesn't change when switching From:

VERIFIED FIXED

Status

MailNews Core
Composition
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Koike Kazuhiko)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
Bcc: field in mail compose window doesn't change when switching From:
field.

(1) Make two account settings.
(2) Check "Bcc <my address>" in Copy and Folder Settings for both account.
(3) Open a mail compose window. Mail address for default account appears
 in Bcc: field.
(4) Switch From: field to the other. Bcc: field disappers.
(Assignee)

Comment 1

17 years ago
Component should be changed to "Composition".
Component: Mail Window Front End → Composition
over to hewitt and ducarroz
Assignee: sspitzer → ducarroz
should have looked for duplicates...

looks like hyatt's popup bug.

*** This bug has been marked as a duplicate of 67472 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
VERIFIED DUP.  That's what I marked my bug a DUP of, too.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 5

17 years ago
bug 67472(bug 67435) was fixed, but this bug still exists.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Yes.  This bug isn't dependant upon Hyatt's bug. (like we first thought.)
QA Contact: esther → fenella
(Assignee)

Comment 7

17 years ago
Created attachment 35782 [details] [diff] [review]
patch
(Assignee)

Comment 8

17 years ago
Please check in the attached patch. It's simple.
Thanks for sending the patch. Reassign to varada
Assignee: ducarroz → varada
Status: REOPENED → NEW

Comment 10

17 years ago
The patch fixes the problem. thanks for the patch kazhik.
r=varada

Comment 11

17 years ago
BuildID:20010608

Now "From:" change will cause "BCC:" to change but only once.
e.g. Account A and B both has BCC set.
Initial compose as from Account A, switch to B, the BCC change 
but if switch back to A, the BCC lost.
sr=blizzard
(Assignee)

Comment 13

17 years ago
Could somebody check in the patch?

Comment 14

17 years ago
This bug is not just present on Win2K (I have the same bug on Linux), so I would
change the OS to "All".  I think it is a quite serious bug because it can cause
inadvertent data loss -- some of us really care about making sure we have logged
ALL outgoing traffic.  Thus, I think "normal" severity is inappropriate for this
bug.

Comment 15

17 years ago
Sorry for the delay, Kazhik (on behalf of us with checkin access).

I will checkin your patch to CVS. Thank you for the contribution.
Assignee: varada → kazhik

Comment 16

17 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 17

17 years ago
win32 (2001-08-22-09 trunk)
Verify that bug is fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.