Last Comment Bug 673836 - Intermittent failure in accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame] - got 0, expected 1
: Intermittent failure in accessible/tree/test_tabbrowser.xul | Different amoun...
Status: RESOLVED FIXED
: access, intermittent-failure
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla8
Assigned To: alexander :surkov
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: a11yrandomorange 438871
  Show dependency treegraph
 
Reported: 2011-07-24 20:49 PDT by alexander :surkov
Modified: 2012-11-25 19:31 PST (History)
0 users
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.68 KB, patch)
2011-08-03 06:55 PDT, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review

Description alexander :surkov 2011-07-24 20:49:07 PDT
mounir
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311536284.1311537894.14716.gz
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/07/24 12:38:04

s: talos-r3-xp-051
18879 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame, address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
Comment 1 Serge Gautherie (:sgautherie) 2011-07-25 18:43:46 PDT
And this other one, from bug 616201 too:
{
TinderboxPushlog Robot      2011-07-25 08:28:44 PDT

ehsan%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311598205.1311599740.6390.gz
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/07/25 05:50:05

s: talos-r3-xp-006
18879 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame, address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
}
Comment 2 Serge Gautherie (:sgautherie) 2011-07-25 19:02:35 PDT
Test unchanged since 2011-03-23.


(In reply to comment #0)
> mounir
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311536284.
> 1311537894.14716.gz
> Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/07/24
> 12:38:04

http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=5e57dacf6ff1
"Ehsan Akhgari – Merge mozilla-central and mozilla-inbound"...


(In reply to comment #1)
> ehsan%mozilla.com
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311598205.
> 1311599740.6390.gz
> Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/07/25
> 05:50:05

http://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=6c5f3085166c
Unrelated OS/2 changeset.
Comment 3 Treeherder Robot 2011-07-26 21:47:21 PDT
philipp%weitershausen.de
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1311735941.1311737594.18996.gz
Rev3 WINNT 5.1 mozilla-central opt test mochitest-other on 2011/07/26 20:05:41

s: talos-r3-xp-059
18931 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame, address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
Comment 4 Treeherder Robot 2011-07-28 09:23:12 PDT
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311867829.1311869331.7269.gz
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/07/28 08:43:49

s: talos-r3-xp-057
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug595020.js | title starts with 'title' - Got -1, expected 0
5509 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_frames.html | wrong extra state bits for  'document node'  [test5: frameUpdateDoc]!got '0', expected 'editable'
5510 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_frames.html | state bits should not be present in ID  'document node'  [test5: frameUpdateDoc]!got 'readonly', expected '0'
5511 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_frames.html | extraState bits should not be present in ID  'document node'  [test5: frameUpdateDoc]!got 'stale', expected '0'
18931 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame, address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
Comment 5 Treeherder Robot 2011-08-01 01:56:05 PDT
mak77%bonardo.net
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1312095184.1312096735.733.gz
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/07/30 23:53:04

s: talos-r3-xp-009
18913 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'tab node' , role: pagetab, name: 'About:', address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
18919 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'tab node' , role: pagetab, name: 'The Book of Mozilla, 11:9', address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
18945 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame, address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
Comment 6 Treeherder Robot 2011-08-02 23:34:39 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1312342855.1312345257.9106.gz
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/08/02 20:40:55

s: talos-r3-xp-043
18965 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame, address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
Comment 7 alexander :surkov 2011-08-03 06:55:28 PDT
Created attachment 550370 [details] [diff] [review]
patch

the problem is document accessible is not attached to the tree yet, so listening a11y events is a right way to proceed it
Comment 8 Treeherder Robot 2011-08-03 21:19:02 PDT
ttaubert
http://tinderbox.mozilla.org/showlog.cgi?log=Fx-Team/1312423679.1312425952.30000.gz
Rev3 WINNT 5.1 fx-team opt test mochitest-other on 2011/08/03 19:07:59

s: talos-r3-xp-031
18965 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tree/test_tabbrowser.xul | Different amount of expected children of [ 'browser node' , role: internal frame, address: [xpconnect wrapped (nsISupports, nsIAccessible, nsIAccessNode)]]. - got 0, expected 1
Comment 9 Marco Zehe (:MarcoZ) on PTO until August 15 2011-08-04 01:56:54 PDT
Comment on attachment 550370 [details] [diff] [review]
patch

Ah, thanks for this change, this makes the test more close to what ATs do. r=me!
Comment 10 alexander :surkov 2011-08-04 02:58:32 PDT
inbound http://hg.mozilla.org/integration/mozilla-inbound/rev/d201bfd052b3
Comment 11 alexander :surkov 2011-08-05 08:49:31 PDT
landed http://hg.mozilla.org/mozilla-central/rev/d201bfd052b3
Comment 12 Serge Gautherie (:sgautherie) 2011-08-05 18:11:54 PDT
Nit: I would have kept |SimpleTest.executeSoon(...);| to let the handler (fully) end first, though this is not required.
Comment 13 alexander :surkov 2011-08-07 19:50:09 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #12)
> Nit: I would have kept |SimpleTest.executeSoon(...);| to let the handler
> (fully) end first, though this is not required.

it makes sense to run tests in sync, that's the way AT do often.

Note You need to log in before you can comment on or make changes to this bug.