Last Comment Bug 673859 - CTRL+Enter to open link in a new tab broken since July 23, 2011 build
: CTRL+Enter to open link in a new tab broken since July 23, 2011 build
Status: VERIFIED FIXED
: access, regression
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: Trunk
: All All
: -- major (vote)
: Firefox 8
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
: 674194 (view as bug list)
Depends on:
Blocks: 646157
  Show dependency treegraph
 
Reported: 2011-07-25 00:13 PDT by Marco Zehe (:MarcoZ)
Modified: 2011-07-28 06:00 PDT (History)
9 users (show)
khuey: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (808 bytes, patch)
2011-07-25 09:39 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
bugs: review+
Details | Diff | Review

Description Marco Zehe (:MarcoZ) 2011-07-25 00:13:59 PDT
STR:
1. Open a page.
2. Tab to a link.
3. Press CTRL+Enter to open the link in a new tab.

Expected: Link should open in new tab.
Actual: Nothing happens.

This is a regression first seen in the July 23, 2011 build. Regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=19348341366b&tochange=887fad3ebc0b
Comment 1 Alice0775 White 2011-07-25 00:56:03 PDT
Regresson window(build-system hourly):
Works:
http://hg.mozilla.org/projects/build-system/rev/8c2293dcca62
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110719 Firefox/8.0a1 ID:20110719090011
Fails:
http://hg.mozilla.org/projects/build-system/rev/09b2569edec2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110719 Firefox/8.0a1 ID:20110719092300
Pushlog:
http://hg.mozilla.org/projects/build-system/pushloghtml?fromchange=8c2293dcca62&tochange=09b2569edec2
Triggered by;
09b2569edec2	Kyle Huey — Bug 646157: Prevent 2^n growth in event dispatch in a chain of nested labels. r=smaug Prior to this patch, Gecko allowed bubbling click events to trigger multiple <label>s, and for the synthetic click events generated by <label>s to also trigger additional <label>s. In contrast, Opera allows only the latter, and Webkit/IE allow neither. Gecko's behavior leads to 2^n events being dispatched in the case of markup like: <label for="thing1" /><input type="foo" name="thing1" /> <label for="thing2" /><input type="foo" name="thing2" /> ... After this patch a bubbling click event triggers at most one <label>, and the synthetic click event cannot trigger additional labels. Our behavior is still not identical to Webkit/IE though, because in Gecko a click event will still bubble up past a <label>, while in Webkit/IE the click event will stop at the <label>.
Comment 2 Alice0775 White 2011-07-25 01:52:56 PDT
This also broke
Shift+Enter to open link in new window.
Alt+Enter to save link.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-25 09:39:45 PDT
Created attachment 548203 [details] [diff] [review]
Patch

We're overwriting the trusted flag on the event, which causes much sadness.
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-07-25 10:36:46 PDT
http://hg.mozilla.org/mozilla-central/rev/58c04967ac5b

This needs a test ...
Comment 5 Thomas Ahlblom 2011-07-26 04:15:55 PDT
*** Bug 674194 has been marked as a duplicate of this bug. ***
Comment 6 Marco Zehe (:MarcoZ) 2011-07-28 06:00:32 PDT
Verified fixed in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110727 Firefox/8.0a1

Note You need to log in before you can comment on or make changes to this bug.