Last Comment Bug 673921 - Non buggy GNU ld wrt debugging symbols when using --gc-sections not properly detected
: Non buggy GNU ld wrt debugging symbols when using --gc-sections not properly ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla8
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 670659
  Show dependency treegraph
 
Reported: 2011-07-25 07:49 PDT by Mike Hommey [:glandium]
Modified: 2011-07-26 11:06 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make build/unix/check_debug_ranges.py properly handle objdump addresses output (1.83 KB, patch)
2011-07-25 07:51 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-07-25 07:49:34 PDT
There is a mistake in the python script from bug 670659 that makes the detection fail to work for e.g. android, because the script fails when converting "00000038", which is not proper octal.
Comment 1 Mike Hommey [:glandium] 2011-07-25 07:51:09 PDT
Created attachment 548183 [details] [diff] [review]
Make build/unix/check_debug_ranges.py properly handle objdump addresses output
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-07-25 08:03:07 PDT
Comment on attachment 548183 [details] [diff] [review]
Make build/unix/check_debug_ranges.py properly handle objdump addresses output

Review of attachment 548183 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 :Ehsan Akhgari (away Aug 1-5) 2011-07-26 11:06:52 PDT
http://hg.mozilla.org/mozilla-central/rev/d55e21854a5b

Note You need to log in before you can comment on or make changes to this bug.