Too Many Popup Windows Should Trigger Error/Warning Dialog

VERIFIED DUPLICATE of bug 29346

Status

--
enhancement
VERIFIED DUPLICATE of bug 29346
18 years ago
14 years ago

People

(Reporter: brianr, Assigned: vishy)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
JavaScript's abilities to pop up message dialogs and browser windows are
commonly abused by spam and porn web sites to pop up many windows containing
advertisements or other annoying cruft. Often, these windows pop up too quickly
to be closed and hook the close window event to open even more windows. The end
result is that the user often must (forcibly) quit the browser in order to stem
the tide of popup messages.

If a web site attempts to pop up too many browser or message windows using
JavaScript in too short of a timeframe, Mozilla should display a dialog box
asking the user if they would like to take corrective action. Corrective actions
might include forcibly closing all popup windows created since the start of the
popup storm, inhibiting the creation of more popup windows for a specified
period of time, or blocking a documents loaded from a given base URL from being
able to pop up windows via JavaScript.

Comment 1

18 years ago
Browser, not engine ---> Browser-General
Assignee: rogerl → asa
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Browser-General
Ever confirmed: true
QA Contact: pschwartau → doronr

Comment 2

18 years ago
i think there is a rfe for stoping popups from happening

Comment 3

18 years ago
over to Apps.
Assignee: asa → vishy
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
ooh yeah...

*** This bug has been marked as a duplicate of 29346 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.