Starting position on multiple monitors: stuck after maximizing on 3rd monitor

RESOLVED DUPLICATE of bug 264030

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 264030
6 years ago
4 years ago

People

(Reporter: mozilla_orders, Unassigned)

Tracking

5 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

I have a three monitor setup on Mac OS X. The dock is on the left (1st) monitor which is at 1920x1200 (portrait), the middle (2nd) monitor is at 1440x900 and the right (3rd) one at 800x600 (a projector).
To reproduce the bug (persistent on all versions of Firefox and OS X I have used for the last couple of years):

1) Maximize firefox on the third monitor.
2) Move firefox to 1st or 2nd monitor and close firefox.
3) Re-open firefox.


Actual results:

Firefox opens on the 3rd monitor.

From the moment you maximize once on the 3rd monitor, the main window starting location on localstore.rdf never gets updated whatever you do, so you are stuck with the window opening on that monitor. For reference, in my case the localstore.rdf gets stuck at:
Description RDF:about="chrome://browser/content/browser.xul#main-window"
                   width="1440"
                   height="600"
                   screenX="2544"
                   screenY="888"
                   sizemode="maximized"



Expected results:

The localstore.rdf main window section should get updated so that when I reopen Firefox it should come up at the same place and same monitor it was when I closed it.
(Reporter)

Updated

6 years ago
OS: Other → Mac OS X

Comment 1

6 years ago
variation of bug 264030?

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264030
You need to log in before you can comment on or make changes to this bug.